Bug 496070 - Entry from PAB doesn't appear in names list when 'To:' is hit
Entry from PAB doesn't appear in names list when 'To:' is hit
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: evolution-data-server (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Matthew Barnes
desktop-bugs@redhat.com
:
Depends On:
Blocks: 499522
  Show dependency treegraph
 
Reported: 2009-04-16 09:28 EDT by Alan Matsuoka
Modified: 2010-10-05 14:16 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-05 14:16:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
testvcard.vcf (296 bytes, text/x-vcalendar)
2009-04-16 09:28 EDT, Alan Matsuoka
no flags Details
evolution-data-server-1.12.3-fix-case.patch (2.46 KB, patch)
2009-04-16 09:29 EDT, Alan Matsuoka
no flags Details | Diff

  None (edit)
Description Alan Matsuoka 2009-04-16 09:28:05 EDT
Description of problem:
    When creating a new email, then clicking on the "To:" button to look up an email recipient in an address list, an entry in the Personal Address Book does not appear in the "Select contacts" window.

How reproducible:

Steps to Reproduce:
    Open Evolution.  Go to Contacts.  Import an ".vcf" file/card -- preferably Chris Evich's, since this card was the one noted in the issue report -- and verify its presence after the import.  Switch back to "Mail" view.  Click on "New" to star a new email.  Click on the "To:" button next to the "To:" line to pull up the "Select contacts" window.  Find & select the "Personal" address list.  Likely note that Chris Evich is not there.

Actual results:
    A given "Personal" entry, previously imported to the PAB via the Evolution "Import..." function, does not appear.

Expected results:
    As in the past, manually entered and imported "Personal" contacts should consistently show up in both the "Contacts" view as well as in address look-ups.

Additional info:
    Uploading a screen shot (sorry for the space-embedded-in-the-names condition) showing a sample of the above-noted behavior: a new email, with the "To:" button having been clicked on, superimposed over a view of the PAB with the apparently-unavailable entry clearly showing up.

Notes from SEG:


Patch attached. There were some inconsistent string compares. Vcard fields are supposed to be case independent.
Comment 1 Alan Matsuoka 2009-04-16 09:28:45 EDT
Created attachment 339841 [details]
testvcard.vcf
Comment 2 Alan Matsuoka 2009-04-16 09:29:21 EDT
Created attachment 339842 [details]
evolution-data-server-1.12.3-fix-case.patch
Comment 7 RHEL Product and Program Management 2010-08-09 15:38:39 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Note You need to log in before you can comment on or make changes to this bug.