Bug 496083 - mock doesn't have configuration for i586
mock doesn't have configuration for i586
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mock (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-16 10:34 EDT by Petr Lautrbach
Modified: 2013-01-10 00:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-15 08:45:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Lautrbach 2009-04-16 10:34:51 EDT
Description of problem:

Since Fedora 11 switched from i386 to i586 default for x86 32bit packages, mock should has configuration for fedora-rawhide-i586 chroot.
Comment 1 Jesse Keating 2009-04-16 12:21:02 EDT
I thought the default was to build for i586 based on rpm macros... what happens when you build into the i386 chroot of rawhide?
Comment 2 Petr Lautrbach 2009-04-17 03:31:49 EDT
My fail, sorry. I didn't check cfg file on rawhide.

This is related to Fedora 10 - mock-0.9.14-1.fc10.noarch

in /etc/mock/fedora-rawhide-i386.cfg is set:
config_opts['target_arch'] = 'i386'

So "$ mock -r fedora-rawhide-i386 package.src.rpm" builds i386 rpms


In rawhide - mock-0.9.14-3.fc11.noarch - is target_arch already set to i586:
config_opts['target_arch'] = 'i586'
Comment 3 Clark Williams 2009-07-08 12:46:49 EDT
so should we close this one?
Comment 4 Petr Lautrbach 2009-07-15 08:45:42 EDT
it's fixed in mock-0.9.16-1.fc10.noarch

Note You need to log in before you can comment on or make changes to this bug.