Bug 496091 - gpk-repo can't see some repos
gpk-repo can't see some repos
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks: PrestoTestDay
  Show dependency treegraph
 
Reported: 2009-04-16 11:16 EDT by Michal Nowak
Modified: 2013-03-07 21:05 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-03 05:38:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Nowak 2009-04-16 11:16:34 EDT
Description of problem:

Having such repo in yum.conf nor repos.d/presto won't be seen in gpk-repo

[PrestoTestDay]
name=PrestoTestDay F11 Snapshot1 with drpms
baseurl=http://skvidal.fedorapeople.org/presto-test/x86_64/Packages/
enabled=1
gpgcheck=0

but the repo obviously works when I ran yum from terminal.

Version-Release number of selected component (if applicable):

PackageKit-0.4.6-3.fc11.x86_64
gnome-packagekit-2.27.2-0.2.20090414git.fc11.x86_64

How reproducible:

always

I don't see any error msg or something like that.
Comment 1 Michal Nowak 2009-04-16 11:20:07 EDT
(Added blocks bug PrestoTestDay as requested from yum-presto QA.)
Comment 2 Richard Hughes 2009-04-16 12:10:19 EDT
It appears pk-backend-yum filters out lines starting with "Presto" from the stdout, possibly because presto has been so vocal (just printing to stdout, rather than using the logging framework) in the past.

If you want a quick fix, rename the repo name to [presto-test-day] and change the name to "presto Test Day F11 Snapshot1 with drpms" as it's case sensitive.

I'll obviously remove the Presto filter line from PackageKit, and can build you a package if you desire.
Comment 3 Richard Hughes 2009-04-16 12:11:25 EDT
commit 1186bd2309879ff83cb57a1cbbf4f65949826d1e
Author: Richard Hughes <richard@hughsie.com>
Date:   Thu Apr 16 17:10:17 2009 +0100

    bugfix: don't filter out 'Presto' unconditionally from the stdout to fix rh#496091
Comment 4 Michal Nowak 2009-04-16 12:22:51 EDT
Thanks for the fix! I guess I was the only one complaining in the test day, so, the hotfix won't be necessary IMO.

Note You need to log in before you can comment on or make changes to this bug.