Bug 496092 - libvirt runs qemu with '-drive fmt=' rather than '-drive format='
libvirt runs qemu with '-drive fmt=' rather than '-drive format='
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11VirtTarget
  Show dependency treegraph
 
Reported: 2009-04-16 11:23 EDT by Mark McLoughlin
Modified: 2009-04-16 12:14 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-16 12:14:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
libvirt-0.6.2-qemu-drive-format.patch (1.01 KB, patch)
2009-04-16 11:23 EDT, Mark McLoughlin
no flags Details | Diff

  None (edit)
Description Mark McLoughlin 2009-04-16 11:23:20 EDT
Created attachment 339858 [details]
libvirt-0.6.2-qemu-drive-format.patch

If you have e.g.

  <disk type='file' device='disk'>
    <source file='/var/lib/libvirt/images/f11-beta.snap1.qcow2'/>
    <target dev='hda' bus='ide'/>
    <driver name='qemu' type='qcow2'/>
  </disk>

then you get:

  qemu: unknown parameter 'fmt' in 'if=ide,index=0,file=/var/lib/libvirt/images/f11-beta.snap1.qcow2,fmt=qcow2'

Turns out qemu takes '-drive format=' not '-drive fmt='

Simple patch attached
Comment 1 Mark McLoughlin 2009-04-16 11:31:31 EDT
Building this:

* Thu Apr 16 2009 Mark McLoughlin <markmc@redhat.com> - 0.6.2-2.fc11
- Fix qemu drive format specification (#496092)

Will request it be tagged into dist-f11
Comment 2 Mark McLoughlin 2009-04-16 12:14:50 EDT
Okay, it's tagged into dist-f11

Note You need to log in before you can comment on or make changes to this bug.