Bug 49610 - login banners
login banners
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: redhat-release (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-21 11:48 EDT by Michal Jaegermann
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-21 11:48:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2001-07-21 11:48:32 EDT
Description of Problem:

Current "Fairfax"  provides in /etc/issue and /etc/issue.net "fixed"
login banners with a string 'Kernel \r on an \m'.  What, on earth, give
you an idea that a tty supplying program will be able to interpret
these escapes?  If for a "regular" console there is a fair chance that
this will be mingetty, although this is far from given, it is quite
unlikely that whatever used on serial lines or network connections will
have this ability.

In particular if you will telnet to a machine running Fairfax to itself
you will be greeted by the following:

Escape character is '^]'.
Red Hat Linux release 7.1.92 (Fairfax)
Kernel \r on an \m
login:

"Old hands" will shrug and replace; often they run custom banners anyway.
Newbies will be terminally baffled.  Note that "fixing" /etc/issue.net
still does nothing for serial connections or alternate getty programs.
Comment 1 Bill Nottingham 2001-07-23 14:37:33 EDT
That was a telnet-server bug, which has since been fixed.

FWIW, everything in the distro (telnet-server, mingetty, mgetty, agetty)
all support the same sequences.
Comment 2 Dean Oliver 2001-07-24 18:25:23 EDT
Upgrading from 7.0 to fairfax beta2 causes /etc/issue not to be updated, thus resulting in the login banner to display kernel version 2.2.16-22, /proc/version showing 2.4.6-2.

Note You need to log in before you can comment on or make changes to this bug.