Bug 496143 - new mv xattr-preservation behavior can be very noisy ....
new mv xattr-preservation behavior can be very noisy ....
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: coreutils (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Ondrej Vasik
BaseOS QE
:
Depends On: 496142
Blocks: 513153
  Show dependency treegraph
 
Reported: 2009-04-16 16:26 EDT by Eric Sandeen
Modified: 2009-09-02 05:17 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 496142
: 513153 (view as bug list)
Environment:
Last Closed: 2009-09-02 05:17:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Sandeen 2009-04-16 16:26:18 EDT
+++ This bug was initially created as a clone of Bug #496142 +++

In the latest coreutils it attempts to preserve xattrs, and it can lead to very noisy output if the target filesystem does not support xattrs (or, perhaps, does not support selinux xattrs):

root@inode tmp]# mv newdir/ mnt/
mv: setting attributes for `mnt/newdir/file58': Operation not supported
mv: setting attributes for `mnt/newdir/file85': Operation not supported
mv: setting attributes for `mnt/newdir/file68': Operation not supported
mv: setting attributes for `mnt/newdir/file74': Operation not supported
mv: setting attributes for `mnt/newdir/file1': Operation not supported
mv: setting attributes for `mnt/newdir/file69': Operation not supported
mv: setting attributes for `mnt/newdir/file95': Operation not supported
mv: setting attributes for `mnt/newdir/file42': Operation not supported
mv: setting attributes for `mnt/newdir/file77': Operation not supported
mv: setting attributes for `mnt/newdir/file44': Operation not supported
mv: setting attributes for `mnt/newdir/file38': Operation not supported
mv: setting attributes for `mnt/newdir/file36': Operation not supported
mv: setting attributes for `mnt/newdir/file31': Operation not supported
mv: setting attributes for `mnt/newdir/file25': Operation not supported
mv: setting attributes for `mnt/newdir/file57': Operation not supported
mv: setting attributes for `mnt/newdir/file32': Operation not supported
mv: setting attributes for `mnt/newdir/file100': Operation not supported
mv: setting attributes for `mnt/newdir/file89': Operation not supported
.....
mv: setting attributes for `mnt/newdir/file96': Operation not supported
mv: setting attributes for `mnt/newdir': Operation not supported
[root@inode tmp]#

This would happen when copying to a filesystem that does not support selinux, or does not support xattrs - fat, cifs, nfs, mounts with selinux contexts ...

mv /home/myphotos /mnt/vfat-usbstick for example would probably trigger this.

I'm not sure it's worth issuing a warning for every file if the target doesn't support the thing mv is trying to preserve.  For that matter maybe mv should stop trying after the first EOPNOTSUPP?

Thanks,
-Eric
Comment 1 Ondrej Vasik 2009-04-17 04:40:04 EDT
Thanks for report, as there is already a way to silent error messages from
xattr's preserving (done for cp -a), it could be easily used for mv as well...
will do that...
Comment 6 Jan Ščotka 2009-07-22 07:22:54 EDT
cant be reproduced via RHTS, because bug isnt in old version
Comment 8 errata-xmlrpc 2009-09-02 05:17:43 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1262.html

Note You need to log in before you can comment on or make changes to this bug.