Bug 496148 - Provisioning, low impact, 404's during kickstart
Provisioning, low impact, 404's during kickstart
Status: CLOSED NOTABUG
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
530
All Linux
low Severity low
: ---
: ---
Assigned To: Partha Aji
wes hayutin
http://grandprix.rhndev.redhat.com/rh...
:
Depends On:
Blocks: 457075
  Show dependency treegraph
 
Reported: 2009-04-16 16:39 EDT by wes hayutin
Modified: 2011-07-20 08:29 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-23 10:46:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2009-04-16 16:39:25 EDT
Description of problem:

4/14 iso rhel 5 server...

getting a 404 in the tomcat logs.. The kickstart still succeeds so this is *very* low impact

tomcat log

2009-04-16 15:39:43,481 [TP-Processor5] ERROR com.redhat.rhn.frontend.action.common.DownloadFile - /var/satell
ite/rhn/kickstart/ks-rhel-i386-server-5-u3/disc1/.discinfo Not Found .. 404!
2009-04-16 15:39:43,485 [TP-Processor5] ERROR org.apache.catalina.core.ContainerBase.[Catalina].[localhost].[/
rhn].[org.apache.jsp.WEB_002dINF.pages.common.errors._404_jsp] - Servlet.service() for servlet org.apache.jsp.
WEB_002dINF.pages.common.errors._404_jsp threw exception
java.lang.IllegalStateException: getOutputStream() has already been called for this response
        at org.apache.catalina.connector.Response.getWriter(Response.java:601)



/var/satellite/rhn/kickstart/ks-rhel-i386-server-5-u3
[root@grandprix ks-rhel-i386-server-5-u3]# ls disk*
ls: disk*: No such file or directory
[root@grandprix ks-rhel-i386-server-5-u3]#
Comment 1 Clifford Perry 2009-04-17 10:36:24 EDT
The 404's are normal and not harmful. The anaconda code is hard coded to look automatically for certain files, if the files are not available, they do not cause fatal errors for the installation. So if the installation is working, this I am certain can be safely ignored. 

So, going to approve, have Partha review and re-confirm my own statements. I do not see this as being an issue as we can most likely close this out as NOTABUG. 

Thanks, 
Cliff.
Comment 2 Mike McCune 2009-04-17 13:16:51 EDT
like cliff said, the 404s are expected and we have always had them when doing kickstarts.

The only annoying part is that we do spew the log files a bit too much if the file doesn't exist but that is the only real downside.

I'd vote we close as NOTABUG
Comment 3 Mike McCune 2009-04-21 19:18:37 EDT
Moving back to -triage.  Cliff, both Partha and me recommend NOTABUG
Comment 4 Brandon Perkins 2009-04-23 10:46:31 EDT
Closed Not a Bug.
Comment 5 Christian Horn 2011-07-20 08:29:36 EDT
This is problem is still valid for satellite 5.4 .

Note You need to log in before you can comment on or make changes to this bug.