Bug 496162 - proxy 5.3 webui proxy installer fails with apache ssl error
proxy 5.3 webui proxy installer fails with apache ssl error
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite Proxy 5
Classification: Red Hat
Component: Installer (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Miroslav Suchý
wes hayutin
http://grandprix.rhndev.redhat.com/ne...
:
Depends On:
Blocks: 456999 486216
  Show dependency treegraph
 
Reported: 2009-04-16 17:41 EDT by wes hayutin
Modified: 2009-09-10 10:38 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 10:38:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2009-04-16 17:41:03 EDT
Description of problem:

sat 4/14 rhel5 server 

webui proxy 5.3 installer fails w/ 


This action's status is: Failed.
The client picked up this action on 04/16/09 5:35:55 PM EDT.
The client completed this action on 04/16/09 5:36:01 PM EDT.
Client execution returned "Script failed" (code 1)


Run as: root:root
Timeout: 600 seconds

#!/bin/sh
/usr/sbin/rhn-proxy restart


Start Date: 2009-04-16 17:35:55
End Date: 2009-04-16 17:36:00
Return Code: 256
Raw Output: view/download raw script output
Filtered Output:



Going back the sdc for the system.. and clicking proxy..
the proxy displays that it is activated successfully, which it should not if part of the install failed.

Shutting down rhn-proxy...
Shutting down Jabber router: [FAILED]
Stopping httpd: [FAILED]
Stopping squid: [FAILED]
Done.
Starting rhn-proxy...
Starting squid: .[ OK ]
Starting httpd: Syntax error on line 112 of /etc/httpd/conf.d/ssl.conf:
SSLCertificateFile: file '/etc/httpd/conf/ssl.crt/server.crt' does not exist or is empty
[FAILED]
Starting Jabber services[ OK ]
Done.
Comment 1 Clifford Perry 2009-04-17 11:53:45 EDT
Not sure this is a true QA blocker, since command line is primary. Obviously is command line is not functional, then that bug should be the blocker. 

WebUI is supported, but deprecated for 530, so we should be trying to ensure it is functional for 530 release.  QA's primary focus on Proxy installations should be command line installations.

Cliff
Comment 2 Miroslav Suchý 2009-05-14 10:51:04 EDT
I can not reproduce it (with latest ISO). 
I have there:
Shutting down rhn-proxy...
Shutting down Jabber router: [FAILED]
Stopping httpd: [FAILED]
Stopping squid: [FAILED]
Done.
Starting rhn-proxy...
Starting squid: .[ OK ]
Starting httpd: [ OK ]
Starting Jabber services[ OK ]
Done.

Wes can you try it again. And either close this one, or provide more info. Thx.
Comment 3 wes hayutin 2009-05-20 12:58:59 EDT
this is currently working 5/7.1
Comment 4 Jan Pazdziora 2009-09-08 10:20:14 EDT
Stage validated with Satellite 5.3.0 Gold and RHN Proxy 5.3.0 Gold. WebUI installation on RHEL 4 and RHEL 5 without problems. Moving to RELEASE_PENDING.
Comment 5 Brandon Perkins 2009-09-10 10:38:22 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1433.html

Note You need to log in before you can comment on or make changes to this bug.