Bug 496188 - split up boost
split up boost
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: boost (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Petr Machata
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks: 529563
  Show dependency treegraph
 
Reported: 2009-04-17 01:30 EDT by Rahul Sundaram
Modified: 2015-05-04 21:34 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-03 13:19:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Proposed spec patch (8.49 KB, patch)
2009-04-29 13:20 EDT, Petr Machata
no flags Details | Diff

  None (edit)
Description Rahul Sundaram 2009-04-17 01:30:03 EDT
Description of problem:

Boost is in the Fedora Live CD and usually software packages have dependencies on some specific parts of boost such as boost:filesystem and has to depend on boost on the while since unlike say Debian, the Fedora package is a monolithic one. 

It would be useful to split up boost a bit more to save some space. Won't be much but I prefer more granularity here.
Comment 1 Petr Machata 2009-04-29 13:20:37 EDT
Created attachment 341795 [details]
Proposed spec patch

I've had a chance to work on that today.  I'm attaching proposed patch that splits boost up into sub-packages per library.  `boost' package was kept as an umbrella package, it should pull all the other libraries into the system, so that packages that depend on boost by name won't break.  I imagine that most packages depend on SONAME, but didn't check whether that's actually true.

I've consolidated some of the dependencies, so that there is e.g. "boost-math", and not "boost-math-tr1" and "boost-math-c99".  Also "boost-serialization" covers also a wide serialization library.

"boost-devel" was kept intact, since the goal is to reduce the usage of live CD image.  Also intricate inter-dependencies of boost header libraries are nothing I'd want to dissect.

Obviously I welcome any comments that you might have and will act upon them before commiting this into the devel CVS.

Btw, upgrade to 1.39.0 is around the corner.  We can use that event to encourage people to drop their dependence on "boost", if any such exist.  I think the package should still be kept around for third party cruft, and perhaps also user convenience.
Comment 2 Rahul Sundaram 2009-04-30 06:08:21 EDT
Thanks for working on this. After you inherit the new upstream release and split it up, please drop in a mail to fedora-devel-announce list to let the package maintainers know that they need to depend on the specific sub package instead of boost on the whole.  

I don't recommend splitting up the devel packages. Just a single one is fine. 

Again, thanks.
Comment 3 Benjamin Kosnik 2009-05-06 22:31:29 EDT
Ill!!!

I have the update to 1.39 done and will integrate Petr's patch in #1.
Comment 4 Bug Zapper 2009-06-09 09:59:13 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Matthias Clasen 2009-07-01 21:58:53 EDT
Hey, the package split seems to have happened now, but it is defective...

gnote only requires boost-filesystem, but it still pulls all of the boost package onto the live cd. That happens because the boost 'umbrella' package has a file list that still contains all the libraries that are in the subpackages. I don't think that was intended...
Comment 6 Petr Machata 2009-07-02 10:27:30 EDT
Right, that's an omission.  I'm spinning a local build with the file list for main boost package dropped.

Also, reassigning back to rawhide.
Comment 7 Petr Machata 2009-07-02 13:26:24 EDT
A package that should contain fixes to the above was just built.
Comment 8 Bug Zapper 2009-11-16 04:55:48 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Denis Arnaud 2010-02-03 13:19:59 EST
Petr Machata has released the new Boost package (where the libraries have been split up) for rawhide: https://bugzilla.redhat.com/show_bug.cgi?id=559009#c45

The rawhide build is here: http://koji.fedoraproject.org/koji/taskinfo?taskID=1960702

Note You need to log in before you can comment on or make changes to this bug.