Bug 496215 - ISE / 500 when coming to /network/monitoring/scout/index.pxt without being logged in
ISE / 500 when coming to /network/monitoring/scout/index.pxt without being lo...
Status: CLOSED WORKSFORME
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Shannon Hughes
Preethi Thomas
/network/monitoring/scout/index.pxt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-17 07:15 EDT by Jan Pazdziora
Modified: 2009-04-20 21:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-20 06:25:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pazdziora 2009-04-17 07:15:16 EDT
Description of problem:

I've received ISE / 500 on the /network/monitoring/scout/index.pxt page. I think even if I'm not sure that it is related to the web traceback shown below and that it is caused by me clicking on the URL while the session has already expired. I was subsequently able to achieve that ISE by Signing Out from the WebUI and then going directly to the URL.

Version-Release number of selected component (if applicable):

Satellite-5.3.0-RHEL5-re20090403.2 on i386

How reproducible:

Not really sure how deterministic this is.

Steps to Reproduce:
1. Log in to Satellite.
2. In another tab/window, go to https://FQDN/network/monitoring/scout/index.pxt, see it load alright.
3. Click Sign Out in the first tab.
4. Reload that /network/monitoring/scout/index.pxt page.
  
Actual results:

500 Error - Internal Server Error

You may have reached this page in one of the following ways:

   1. You are using an outdated version of Konqueror 3.0, which may not handle form variables properly in all cases. Continuing to use this outdated version of Konqueror may have unexpected results. Please up2date to the latest version of Konqueror (3.03 or greater), or if this is not possible, please use another browser.
   2. You've found an error in the site. Please report this error to your local administrator with details of how you received this message.

Expected results:

No ISE / 500, redirect to log in page or something.

Additional info:

The email web traceback I received which might be related was:

The following exception occurred while executing this request:
 GET /network/monitoring/scout/index.pxt HTTP/1.1 (from browser)
 /network/monitoring/scout/index.pxt (from Apache)

Date:
  Fri Apr 17 12:54:53 2009

Headers:
  Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
  Accept-Charset: UTF-8,*
  Accept-Encoding: gzip,deflate
  Accept-Language: en,en-us;q=0.7,cs;q=0.3
  Connection: keep-alive
  Cookie: rh_omni_tc=70160000000H4AjAAK; s_vi=[CS]v1|49E4A8C400001466-A3A09C2000033B4[CE]; __qca=1224585041-7685865-45702227
  Host: vmware139.englab.brq.redhat.com
  Keep-Alive: 300
  User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.8) Gecko/2009032713 Fedora/3.0.8-1.fc10 Firefox/3.0.8

Form variables:


User Information:
(not logged in)

Error notes:
  (none)

Initial Request:
  Yes

Error message:
  Can't call method "preferred_page_size" on an undefined value at /usr/lib/perl5/vendor_perl/5.8.8/Sniglets/Lists.pm line 117.
Comment 1 Clifford Perry 2009-04-17 11:10:29 EDT
Using fjs-0-03 I was not able to reproduce this. Using exact steps - I got:

https://fjs-0-03.rhndev.redhat.com/rhn/ReLogin.do?url_bounce=/network/monitoring/scout/index.pxt


So for me, it correctly re-directed to the login page as I expected. This was using the 4/14 530 Beta ISO.

Are you able to borrow someone else's Sat to re-confirm bug?  Right now I expect that if re-confirmed, I will move it onto sat530-canfix. 

Cliff.
Comment 2 Jan Pazdziora 2009-04-20 06:25:08 EDT
I confirm that using compose Satellite-5.3.0-RHEL5-re20090414.0-i386 I'm no longer able to reproduce this problem..

Note You need to log in before you can comment on or make changes to this bug.