Bug 496225 - alps touch pad very slow after upgrade from F10 to rawhide
alps touch pad very slow after upgrade from F10 to rawhide
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gsynaptics (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Andreas Thienemann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-17 08:31 EDT by Peter Robinson
Modified: 2009-05-21 08:29 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-21 08:29:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Robinson 2009-04-17 08:31:03 EDT
The Alps touchpad on my Dell D630 is very slow after an upgrade from F10 to rawhide. The pointer in the middle of the keyboard doesn't have any issues and click etc work fine. Increasing the speed in either the mouse or using gsynaptic has no effect. In the gsynaptic applet the Max speed slider on the Acceleration tab is set to the slowest value and always gets reset when changed.

It worked perfectly in F10.

Output from xorg.0.log

(II) config/hal: Adding input device AlpsPS/2 ALPS GlidePoint
(II) LoadModule: "synaptics"
(II) Loading /usr/lib64/xorg/modules/input//synaptics_drv.so
(II) Module synaptics: vendor="X.Org Foundation"
        compiled for 1.6.0, module version = 1.1.0
        Module class: X.Org XInput Driver
        ABI class: X.Org XInput driver, version 4.0
(II) Synaptics touchpad driver version 1.1.0
(**) Option "Device" "/dev/input/event6"
(II) AlpsPS/2 ALPS GlidePoint: x-axis range 0 - 1023
(II) AlpsPS/2 ALPS GlidePoint: y-axis range 0 - 767
(II) AlpsPS/2 ALPS GlidePoint: pressure range 0 - 127
(II) AlpsPS/2 ALPS GlidePoint: finger width range 0 - 0
(II) AlpsPS/2 ALPS GlidePoint: buttons: left right middle
(--) AlpsPS/2 ALPS GlidePoint touchpad found
(**) AlpsPS/2 ALPS GlidePoint: always reports core events
(II) XINPUT: Adding extended input device "AlpsPS/2 ALPS GlidePoint" (type: TOUCHPAD)
(**) AlpsPS/2 ALPS GlidePoint: (accel) keeping acceleration scheme 1
(**) AlpsPS/2 ALPS GlidePoint: (accel) filter chain progression: 2.00
(**) AlpsPS/2 ALPS GlidePoint: (accel) filter stage 0: 20.00 ms
(**) AlpsPS/2 ALPS GlidePoint: (accel) set acceleration profile 0
(--) AlpsPS/2 ALPS GlidePoint touchpad found
(II) config/hal: Adding input device PS/2 Mouse
(**) PS/2 Mouse: always reports core events
(**) PS/2 Mouse: Device: "/dev/input/event5"
(II) PS/2 Mouse: Found 3 mouse buttons
(II) PS/2 Mouse: Found x and y relative axes
(II) PS/2 Mouse: Configuring as mouse
(**) PS/2 Mouse: YAxisMapping: buttons 4 and 5
(**) PS/2 Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
(II) XINPUT: Adding extended input device "PS/2 Mouse" (type: MOUSE)
(**) PS/2 Mouse: (accel) keeping acceleration scheme 1
(**) PS/2 Mouse: (accel) filter chain progression: 2.00
(**) PS/2 Mouse: (accel) filter stage 0: 20.00 ms
(**) PS/2 Mouse: (accel) set acceleration profile 0
(II) config/hal: Adding input device Macintosh mouse button emulation
Comment 1 Peter Hutterer 2009-04-19 22:57:43 EDT
do you see the same problem when you uninstall gsynaptics (or alternatively, start a plain X session without a desktop environment)?
I'm trying to figure out if that's a synaptics or a gsynaptics issue.
Comment 2 Peter Robinson 2009-04-20 06:36:42 EDT
I'll remove gsynaptics as I only installed it in F-10 because I needed to speed up the pad a little so it didn't take two drags to get across the screen. I will update again when I restart X this evening.
Comment 3 Peter Robinson 2009-04-20 15:39:10 EDT
I can confirm that the removal of gsynaptics has fixed this issue. Thanks!
Comment 4 Peter Hutterer 2009-04-20 23:25:37 EDT
reassigning to gsynaptics
Comment 5 Peter Robinson 2009-05-21 08:29:18 EDT
I think gsynaptics has now been replaced with a new app, and this works when its removed so closing

Note You need to log in before you can comment on or make changes to this bug.