This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 496231 - Current Rawhide breaks internet access
Current Rawhide breaks internet access
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
x86_64 Linux
low Severity urgent
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-17 09:10 EDT by Fabian Korak
Modified: 2009-05-25 07:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-25 07:54:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My yum.log (21.88 KB, application/octet-stream)
2009-04-17 09:10 EDT, Fabian Korak
no flags Details

  None (edit)
Description Fabian Korak 2009-04-17 09:10:27 EDT
Created attachment 340000 [details]
My yum.log

Hi, first of all,

Description of problem:
I'm running an up-to-date rawhide. After updating and rebooting a few days ago my internet access broke. NetworkManager was still showing a successful connection, and I was still able to ping stuff(like google.com) and I could reach the configuration page of my router, but I couldn't get http or yum to work. They didn't show errors, but rather just timed out.

Now I tried re-installing Beta 1, to figure out which package was causing this, and so I updated only stuff of which I thought wasn't that important, rebooted, and bang! - same problem. I've added my yum.log, one of the packages in that list must be what is causing it, I'm suspecting iptables.


Additional info:

Please note that I have both SELinux and the Fedora firewall turned off, due to misbehavior in the past(plus it really slows down Ktorrent, and I have a hardware-firewall). If you need any logs please let me know, seeing how I have to downgrade everytime after I update rawhide to trigger this bug.
Comment 1 Thomas Woerner 2009-04-17 10:13:22 EDT
Please attach the output of "iptables-save" and "ip6tables-save".
Comment 2 Fabian Korak 2009-04-17 16:20:34 EDT
Okay, it wasn't iptables, I updated iptables and its dependencies, and Internet is still working - seems like I have to go through that yum.log one by one *sigh*

I'll give feedback when I'm done with that. Any tips on which package could be causing this?
Comment 3 Fabian Korak 2009-04-28 10:33:25 EDT
Okay, after checking all the packages in that log*sigh*, these packages are what causing the bug:

glibc
glibc-common
glibc-headers
glibc-devel
nss-softokn-freebl

Sadly, these are dependencies for installing wine, so I either have no Internet or no Wine.
Comment 4 Remy Maucherat 2009-04-30 07:08:59 EDT
You could check if bug 492700 is related to that issue, if Wine is involved.
Comment 5 Fabian Korak 2009-04-30 09:02:48 EDT
(In reply to comment #4)
> You could check if bug 492700 is related to that issue, if Wine is involved.  

I have my doubts, I didn't have Wine installed when I made that first yum.log. It's just an additional comment why I can't simply never update Glibc and live happily till FC12 Rawhide.
Comment 6 Fabian Korak 2009-05-25 07:54:09 EDT
Fixed in rc1. Probably because nss-softokn-freebl no longer is a dependency.

Note You need to log in before you can comment on or make changes to this bug.