Bug 496249 - building ppc image fails
building ppc image fails
Product: Fedora
Classification: Fedora
Component: livecd-tools (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2009-04-17 10:34 EDT by Thomas J. Baker
Modified: 2009-04-17 10:47 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-04-17 10:47:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Thomas J. Baker 2009-04-17 10:34:23 EDT
I've had success building i386 live cds using livecd-tools on a i386 machine. I'm now trying to build a ppc live cd using the same kickstart file (modified to point to ppc repos) on he same machine and it's failing saying it can't find the kernel package:

Retrieving http://mirrors.kernel.org/fedora/releases/9/Everything/ppc/os/repodata/repomd.xml ...OK
Retrieving http://mirrors.kernel.org/fedora/releases/9/Everything/ppc/os/repodata/primary.sqlite.bz2 ...OK
Retrieving http://mirrors.kernel.org/fedora/updates/9/ppc.newkey/repodata/repomd.xml ...OK
Retrieving http://mirrors.kernel.org/fedora/updates/9/ppc.newkey/repodata/primary.sqlite.bz2 ...OK
Retrieving http://mirrors.kernel.org/fedora/updates/9/ppc/repodata/repomd.xml ...OK
Retrieving http://mirrors.kernel.org/fedora/updates/9/ppc/repodata/primary.sqlite.bz2 ...OK
Error creating Live CD : Failed to find package 'kernel' : No package(s) available to install

Is this supposed to work? Am I overlooking something? I know the kernel package is part of the repo. I admit to being unfamiliar with ppc machines so I don't know if there's some other package that I should include.
Comment 1 Jeremy Katz 2009-04-17 10:43:54 EDT
You're building the ppc live image on an i386 machine?  That can't work -- we have to install the packages, including running all the scriptlets, etc and so you have to be on a compatible arch
Comment 2 Thomas J. Baker 2009-04-17 10:47:56 EDT
OK, thanks.

Note You need to log in before you can comment on or make changes to this bug.