Bug 496251 - evolution-data-server eats up all system memory
evolution-data-server eats up all system memory
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution-data-server (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-17 10:36 EDT by Larry O'Leary
Modified: 2009-04-17 16:50 EDT (History)
2 users (show)

See Also:
Fixed In Version: evolution-data-server-2.24.5-5.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-17 11:51:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 564727 None None None Never

  None (edit)
Description Larry O'Leary 2009-04-17 10:36:21 EDT
Description of problem:

evolution-data-server appears to have a severe memory leak that results in the process using up all available memory and most of swap memory until eventually oom-killer terminates the process (along with many other system processes).  

This issue makes it impossible to run Evolution for more than a couple of hours and not at all if any other memory hungry application is running.

Version-Release number of selected component (if applicable): 2.24.5

How reproducible:

It appears that the issue is very noticeable if CalDAV calendars are defined.  My system goes into a swap in/out cycle after about 4 hours with nothing else running and oom-killer is finally executed on many processes after about 8 hours. 

Additional info:

It appears this issue was logged as http://bugzilla.gnome.org/show_bug.cgi?id=564727 and has been fixed in head.
Comment 1 Milan Crha 2009-04-17 11:51:56 EDT
Could you try to update to this [1] package, please? It will fix your issue for sure. Thanks.

[1] https://admin.fedoraproject.org/updates/F10/FEDORA-2009-3413
    evolution-data-server-2.24.5-5.fc10
Comment 2 Larry O'Leary 2009-04-17 16:50:08 EDT
Thanks.  So far so good.  It is probably too early to tell but I will say that evolution-data-server is now only eating up 34MB after 10 minutes vs 350MB after 10 minutes.  

I'll be sure to log any new issues if I run into any.

Note You need to log in before you can comment on or make changes to this bug.