Bug 496276 - Audio in presentation plays twice.
Audio in presentation plays twice.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-17 11:45 EDT by David Woodhouse
Modified: 2009-04-23 03:27 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-23 03:27:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2009-04-17 11:45:26 EDT
I had a video in a presentation. When I attempted to play it in dual-head mode (the external display of my laptop connected to the projector), the video is played twice -- once on the external display, and once in a part of my laptop's screen. This is fine.

The problem is that the audio is also played twice, about a second or so out of sync. So it's like a horrible echo.

(This is the first time I've seen pulseaudio actually doing its job, rather than just causing breakage for audio apps. And it's doing precisely the wrong thing.)
Comment 1 Caolan McNamara 2009-04-17 11:57:37 EDT
Not impressed then that it plays anything in the first place :-)

So you've got external monitor plugged in, and mirror monitors turned on with the same stuff getting displayed on both ? or did you get the "speaker notes" screen presenter on your laptop with presentation on projector with the video playing in both ?
Comment 2 David Woodhouse 2009-04-17 13:48:29 EDT
Not mirrored; the external screen is 'right of' the laptop's own display.

So on the laptop I see the speaker notes -- which is _really_ nice apart from the duplicated audio.
Comment 3 Caolan McNamara 2009-04-17 18:10:15 EDT
I imagine no-one considered the scenario before and we need to turn off audio for speaker notes embedded video somehow :-)
Comment 4 Caolan McNamara 2009-04-18 11:09:36 EDT
Need to silence presenter-screen audio
Comment 5 Caolan McNamara 2009-04-19 18:00:55 EDT
Fix checked in, will be in >= 3.1.0-10.2
Comment 6 Caolan McNamara 2009-04-23 03:27:32 EDT
sounds right in 3.1.0-10.2

Note You need to log in before you can comment on or make changes to this bug.