This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 496278 - Xorg cannot start with kernel 2.6.29.1-30
Xorg cannot start with kernel 2.6.29.1-30
Status: CLOSED DUPLICATE of bug 494058
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-17 11:50 EDT by Bryan Christ
Modified: 2009-04-28 23:09 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-28 23:09:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci output (11.84 KB, text/plain)
2009-04-21 22:15 EDT, Bryan Christ
no flags Details

  None (edit)
Description Bryan Christ 2009-04-17 11:50:30 EDT
Description of problem:

When booting with kernel 2.6.29.1-30 Xorg fails to start.  Instead, I get a blinking cursor in the top-left corner.

Version-Release number of selected component (if applicable):


How reproducible: 100%


Steps to Reproduce:
1.  Install kernel 2.6.29.1-30 via yum
2.  Reboot.
3.  Wait for blinking cursor.
  
Actual results:


Expected results:


Additional info:

The problem goes away when booting to the previous 2.6.27.19-170.2.35 kernel.
Comment 1 Chuck Ebbert 2009-04-21 07:46:44 EDT
Please post the output of the command 'lspci -vnn'.
Comment 2 Bryan Christ 2009-04-21 22:15:21 EDT
Created attachment 340664 [details]
lspci output
Comment 3 Chuck Ebbert 2009-04-23 18:16:16 EDT
01:00.0 VGA compatible controller [0300]: nVidia Corporation Quadro FX 570M [10de:040c] (rev a1) (prog-if 00 [VGA controller])

What graphics driver is being used? (nouveau is known to be broken.)

Can you attach the contents of /etc/X11/xorg.conf if it exists?
Comment 4 Bryan Christ 2009-04-23 21:37:28 EDT
Yes.  I am using the nouveau driver.  I'll try the nv driver.  My understanding is that the nv driver is being mostly abandonded for the nouveau driver though.
Comment 5 Bryan Christ 2009-04-23 21:51:28 EDT
The problem goes away with the nv driver, but I would suggest this only be a short-term solution.  Certainly with F11 this should be more closely looked at (the nouveau bug).
Comment 6 Chuck Ebbert 2009-04-28 23:09:32 EDT
nouveau should be working in fedora 11

*** This bug has been marked as a duplicate of bug 494058 ***

Note You need to log in before you can comment on or make changes to this bug.