Bug 496279 - Emergency shell for Live images unusable
Emergency shell for Live images unusable
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-17 11:50 EDT by John Florian
Modified: 2009-04-17 12:44 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-17 12:44:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix emergency shell bash that is unbound to console (429 bytes, patch)
2009-04-17 11:50 EDT, John Florian
no flags Details | Diff

  None (edit)
Description John Florian 2009-04-17 11:50:31 EDT
Created attachment 340027 [details]
Patch to fix emergency shell bash that is unbound to console

Description of problem:
If a Live image encounters an bug in initramfs /init, the system will drop you to a bash shell and wish you luck.  Unfortunately luck will not be enough since bash will not be bound to the console and any user input will be just echoed back to you, but never acted upon.

Patch has been attached.

Version-Release number of selected component (if applicable):
mkinitrd-6.0.71-4.fc10.src.rpm

How reproducible:
You'll need a bug or simply adding an 'exit 1' within the /init that mkliveinitrd generates will suffice.

Steps to Reproduce:
1. Introduce a "bug" as just described.
2. Make a live image.
3. Boot the live image and attempt to run 'ls' or anything from the bash shell that is started.
  
Actual results:
You'll see what you type, but nothing more.

Expected results:
Commands should execute, which would make it much easier to find your bug, assuming of course it's more complex than the fake "exit 1" bug.

Additional info:
The attached patch will fix it.
Comment 1 Jeremy Katz 2009-04-17 12:44:44 EDT
This is actually fixed in current rawhide mkinitrd.  If we push an update of mkinitrd to F10 for other reasons, I'll make sure this gets pulled in, otherwise, it's a "fixed in F11"

Note You need to log in before you can comment on or make changes to this bug.