Bug 496293 - GDM hanging on authentication right after login (with 2.6.29 kernel)
GDM hanging on authentication right after login (with 2.6.29 kernel)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: thinkfinger (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Orphan Owner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-17 12:19 EDT by Denis Leroy
Modified: 2009-12-18 04:16 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 04:16:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Denis Leroy 2009-04-17 12:19:26 EDT
The 2.6.29 kernel upgrade has caused a GDM regression for me with F-10. This is on a T61 (nVidia Quadrio NVS 140M graphics chip). Booting with 2.6.27 doesn't trigger the problem.

The login process seems to hang right after entering the password. Using gdb to attach to the process, it seems /usr/libexec/gdm-session-worker crashed in the pam library during a realloc() call, seemingly because of a memory corruption issue. (realloc call at pam_modutil_getpwnam.c:41). The problem doesn't always occur, about 50% of the time.
Comment 1 Eric Sandeen 2009-04-17 12:50:19 EDT
Just to double check, do you also have the proprietary nvidia driver, or is this with an untainted kernel?
Comment 2 Denis Leroy 2009-04-17 13:23:54 EDT
The problem occurs in both scenarios (with nv and nvidia).
Comment 3 Denis Leroy 2009-04-18 11:27:25 EDT
Is there any way to run gdm-session-worker stand-alone with the right environment variables and arguments, which would give me a chance to run it under valgrind ?

I'm going to upgrade to F-11 fairly quickly, so I may not be able to reproduce this in the future...
Comment 4 Denis Leroy 2009-04-18 12:41:26 EDT
The culprit is thinkfinger (my T61 has a fingerprint scanner). Its pam module is crashing during authentication from gdm-session-worker. Uninstalling thinkfinger fixed it.
Comment 5 James Cassell 2009-04-18 17:11:01 EDT
(In reply to comment #4)
> The culprit is thinkfinger (my T61 has a fingerprint scanner). Its pam module
> is crashing during authentication from gdm-session-worker. Uninstalling
> thinkfinger fixed it.  

I was afraid of this; I remember seeing thinkfinger being orphaned ( https://www.redhat.com/archives/fedora-devel-list/2008-December/msg00165.html )

I haven't noticed crashing, but on my machine, it just hangs for a while (as much as 30 seconds) before letting me in.
Comment 6 Bug Zapper 2009-11-18 04:12:58 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Bug Zapper 2009-12-18 04:16:19 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.