Bug 496301 - cpufreq not working on ASUS F3E/Core2Duo T8300
cpufreq not working on ASUS F3E/Core2Duo T8300
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-17 13:11 EDT by Jan "Yenya" Kasprzak
Modified: 2010-07-20 08:47 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 07:53:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output (52.98 KB, application/octet-stream)
2009-07-25 07:48 EDT, Chris Parkin
no flags Details

  None (edit)
Description Jan "Yenya" Kasprzak 2009-04-17 13:11:29 EDT
Description of problem:
On my laptop (ASUS F3E with the Intel chipset and Core2Duo T8300 CPU), the CPU frequency scaling does not work with the Fedora 10 distribution kernel, the frequency is stuck at maximum (2.4 GHz). With vanilla kernel (at least 2.6.28 to 2.6.30-rc2) I have compiled myself, it works as expected. According to /sys/devices/system/cpu/cpu0/cpufreq/scaling_driver from my own kernel, the scaling driver used is acpi-cpufreq.

Version-Release number of selected component (if applicable):
All kernels since the F10 release (sorry I did not get time to report this earlier), for example any of the following ones:
kernel-2.6.27.15-170.2.24.fc10.x86_64
kernel-2.6.27.19-170.2.35.fc10.x86_64
kernel-2.6.27.21-170.2.56.fc10.x86_64


How reproducible:
100 %

Steps to Reproduce:
1. Boot Fedora 10 on an ASUS F3E laptop
2. on an idle system, run "grep MHz /proc/cpuinfo"
or 3. run GNOME cpufreq-applet in a desktop session
  
Actual results:
The frequency reported is 2.4 GHz, the GNOME applet pops up a window saying "CPU frequency scaling unsupported".

Expected results:
The idle computer should run at 800 MHz and scale up the frequency as needed.


Additional info:
I did not found anything interesting when comparing the dmesg(8) output from my own kernel to the distribution one.

I am not sure whether the problem was also in F9.

This problem may be related to bug #468802.
Comment 1 Chris Parkin 2009-04-27 10:29:03 EDT
Similar problem here on an x48 motherboard with an e8500 cpu.
Although I find it works ok on 
kernel-2.6.27.15-170.2.24.fc10.x86_64
but not on 
kernel-2.6.27.19-170.2.35.fc10.x86_64 or
kernel-2.6.27.21-170.2.56.fc10.x86_64
Comment 2 Jan "Yenya" Kasprzak 2009-06-08 05:54:37 EDT
Still present in 2.6.29.4-167.fc11.x86_64, changing Version: to F10.
Comment 3 Jan "Yenya" Kasprzak 2009-07-01 11:08:30 EDT
Apparently to fix the problem it is sufficient to do

modprobe acpi_cpufreq
echo ondemand > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
echo ondemand > /sys/devices/system/cpu/cpu1/cpufreq/scaling_governor

before logging into the GNOME session. So the problem is that the acpi_cpufreq module is not being loaded automatically. My own vanilla kernels have this module built in, and I also select the ondemand governor as a default in my kernel config.

I am not sure about a proper fix in Fedora startup scripts, though.
Comment 4 Dave Jones 2009-07-23 10:25:26 EDT
it should be getting loaded by the cpuspeed service, make sure that's enabled.

If it is already enabled, can you boot the fedora kernel with cpufreq.debug=7, and attach the dmesg please?
Comment 5 Chris Parkin 2009-07-25 07:48:13 EDT
Created attachment 355140 [details]
dmesg output

dmesg output for me:
Comment 6 Jan "Yenya" Kasprzak 2009-10-09 04:47:53 EDT
(in reply to comment #4)

My cpuspeed service has not been enabled. chkconfig cpuspeed on fixed the problem for me, sorry for the noise.

Before closing the bug please wait for Chris Parkin's response whether his problem is the same.
Comment 7 Chris Parkin 2009-10-10 16:58:17 EDT
I cannot start the cpuspeed service.
running cpuspeed in a shell fails to start it as well:

[root@warpcore ~]# cpuspeed
Error: Could not find any CPUFreq controlled CPU cores to manage
Comment 8 Chuck Ebbert 2009-10-13 09:16:30 EDT
(In reply to comment #7)
> I cannot start the cpuspeed service.
> running cpuspeed in a shell fails to start it as well:
> 
> [root@warpcore ~]# cpuspeed
> Error: Could not find any CPUFreq controlled CPU cores to manage  

Your BIOS is apparently broken and does not support cpufreq:

acpi-cpufreq: acpi_cpufreq_cpu_init
ACPI Warning (dsobject-0502): Package List length (1D) larger than NumElements count (3), truncated
 [20081204]
ACPI Warning (nspredef-0940): \_PR_.CPU0._PSS: Return Package type mismatch at index 2 - found Integer, expected Package [20081204]
ACPI: Invalid package argument
ACPI Exception (processor_perflib-0297): AE_BAD_PARAMETER, Invalid _PSS data [20081204]
[Firmware Bug]: BIOS needs update for CPU frequency support
Comment 9 Chris Parkin 2009-10-13 16:23:07 EDT
It worked fine under kernel-2.6.27.15-170.2.24.fc10.x86_64
And works fine under Windows
But it's not worked under linux since kernel-2.6.27.19-170.2.35.fc10.x86_64
M/B is a LANPARTY DK X48-T2RSB PLUS
Comment 10 Bug Zapper 2010-04-27 09:44:21 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Bug Zapper 2010-06-28 07:53:04 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.