Bug 496314 - Touchpad is not working
Touchpad is not working
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
i686 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-17 14:42 EDT by Stojan Dimitrovski
Modified: 2009-10-07 19:04 EDT (History)
6 users (show)

See Also:
Fixed In Version: 2.6.30.5-43.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-07 19:04:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The Xorg log. (67.66 KB, text/plain)
2009-04-17 14:42 EDT, Stojan Dimitrovski
no flags Details
Output from evtest (1.77 KB, text/plain)
2009-04-20 06:32 EDT, Stojan Dimitrovski
no flags Details

  None (edit)
Description Stojan Dimitrovski 2009-04-17 14:42:27 EDT
Created attachment 340067 [details]
The Xorg log.

Description of problem:
The touchpad is not working. Only the two physical buttons are working.

Version-Release number of selected component (if applicable):
1.1.0-2

How reproducible:
Be using an ETPS/2 Elantech Touchpad, install from Fedora 11 Snapshot 1.

Actual results:
Touchpad which doesn't work, i.e. doesn't sense touch. Only the two buttons are operational.

Expected results:
A working touchpad.

Additional info:
I ran xidump --list and got:
Virtual core pointer           disabled
Virtual core keyboard          keyboard
Macintosh mouse button emulation extension
ETPS/2 Elantech Touchpad       extension
AT Translated Set 2 keyboard   extension
Sleep Button (CM)              extension
Power Button (CM)              extension
Video Bus                      extension
Logitech USB-PS/2 Optical Mouse extension

I then ran xidump "ETPS/2 Elantech Touchpad" to test the device, again, nothing worked except the two buttons.
Comment 1 Stojan Dimitrovski 2009-04-18 17:47:42 EDT
I forgot to mention, the touchpad wasn't working on the livecd/usb.
Comment 2 Peter Hutterer 2009-04-19 23:05:42 EDT
please get and compile evtest from http://people.freedesktop.org/~whot/evtest.c. Then run it against the device file and post the output here when you move your finger around on the touchpad.
Note that you have to stop or vt-switch away from the X server to ensure that evtest can capture the device's events. Synaptics grabs the device and you won't see any output when X is running.
Comment 3 Stojan Dimitrovski 2009-04-20 06:32:25 EDT
Created attachment 340313 [details]
Output from evtest
Comment 4 Stojan Dimitrovski 2009-04-20 06:36:05 EDT
I didn't get anything from touching the touchpad with switched VTs. As you can see, only the physical buttons showed up.
Comment 5 Peter Hutterer 2009-04-20 23:23:15 EDT
I'll have to reassign to the kernel. If evtest doesn't show anything coming out of the kernel, we can't do much in the driver.
Comment 6 Bug Zapper 2009-06-09 10:01:37 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Jaak Simm 2009-06-13 11:38:46 EDT
Confirming. After I upgraded my F10 to F11 the Elantech touchpad of my laptop stopped working. Seems to be the same behavior as already reported, pressing buttons works, but moving cursor does not work.

There are following lines in /var/log/messages during boot:

Jun 14 00:03:55 localhost kernel: elantech.c: Synaptics capabilities query result 0x02, 0x02, 0x64.
Jun 14 00:03:55 localhost kernel: input: ETPS/2 Elantech Touchpad as /devices/platform/i8042/serio4/input/input6
Jun 14 00:03:55 localhost kernel: psmouse.c: bad data from KBC - timeout
Jun 14 00:03:55 localhost kernel: psmouse.c: bad data from KBC - timeout
Jun 14 00:03:55 localhost kernel: psmouse.c: bad data from KBC - timeout
Jun 14 00:03:55 localhost kernel: psmouse.c: bad data from KBC - timeout
Jun 14 00:03:55 localhost kernel: psmouse.c: bad data from KBC - timeout
Jun 14 00:03:55 localhost kernel: psmouse.c: bad data from KBC - timeout
Jun 14 00:03:55 localhost kernel: psmouse.c: bad data from KBC - timeout
Jun 14 00:03:55 localhost kernel: psmouse.c: bad data from KBC - timeout
Jun 14 00:03:55 localhost kernel: psmouse.c: bad data from KBC - timeout

I checked the old messages logs from F10 and these lines were not present. No mention of elantech or Synaptics at all, but touchpad worked fine in F10.

I can provide more information if needed.
Comment 8 Jaak Simm 2009-06-13 12:50:42 EDT
I forgot to post the kernel versions:
F10 (working): kernel-2.6.27.24-170.2.68.fc10.i686
F11 (not-working): kernel-2.6.29.4-167.fc11.i586

I also tried booting my upgraded F11 with F10 kernel. The touchpad works without problems if I boot F11 with F10 kernel (kernel-2.6.27.24-170.2.68.fc10.i686).

And following lines are in /var/log/messages:

Jun 14 01:28:15 localhost kernel: PNP: PS/2 Controller [PNP0303:PS2K,PNP0f13:PS2M] at 0x60,0x64 irq 1,12
Jun 14 01:28:15 localhost kernel: i8042.c: Detected active multiplexing controller, rev 1.1.
Jun 14 01:28:15 localhost kernel: serio: i8042 KBD port at 0x60,0x64 irq 1
Jun 14 01:28:15 localhost kernel: serio: i8042 AUX0 port at 0x60,0x64 irq 12
Jun 14 01:28:15 localhost kernel: serio: i8042 AUX1 port at 0x60,0x64 irq 12
Jun 14 01:28:15 localhost kernel: serio: i8042 AUX2 port at 0x60,0x64 irq 12
Jun 14 01:28:15 localhost kernel: serio: i8042 AUX3 port at 0x60,0x64 irq 12

If required I can test some more kernels to see where the regression occurred.
Comment 9 Chuck Ebbert 2009-06-15 22:02:50 EDT
Try adding "pci=nomsi" to the kernel boot options.
Comment 10 Jaak Simm 2009-06-16 05:37:13 EDT
"pci=nomsi" did not have any effect, touchpad does not work and same lines in /var/log/messages
Comment 11 Stojan Dimitrovski 2009-06-16 07:01:00 EDT
Same here.
Comment 12 Jaak Simm 2009-06-22 06:56:32 EDT
Small update, namely, the bug does not happen always. I've booted my laptop with F11 kernel about 10 times and one of these boots gave me a working touchpad (having the same log in /var/log/messages as F10 kernel).

I haven't done more extensive testing, thus it is hard to tell whether it was just a lucky boot or there were some external factors present.
Comment 13 Jaak Simm 2009-10-05 09:37:22 EDT
It seems the kernel 2.6.30.5-43.fc11.i586 has solved the touchpad problem in my case. Have used it for few weeks now without any problems.

Note You need to log in before you can comment on or make changes to this bug.