Bug 496324 - Segfault in gvfs-gdu-volume-monitor
Segfault in gvfs-gdu-volume-monitor
Status: CLOSED DUPLICATE of bug 496228
Product: Fedora
Classification: Fedora
Component: gvfs (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11Blocker/F11FinalBlocker
  Show dependency treegraph
 
Reported: 2009-04-17 16:15 EDT by James
Modified: 2015-03-03 17:40 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-17 18:41:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gdb transcript for gvfs-gdu-volume-monitor (4.74 KB, text/plain)
2009-04-17 17:33 EDT, James
no flags Details

  None (edit)
Description James 2009-04-17 16:15:24 EDT
Description of problem:
I'm seeing crashes in gvfs-gdu-volume-monitor:

gvfs-gdu-volume[6884]: segfault at 0 ip (null) sp 00007fff407e5ca8 error 14 in gvfs-gdu-volume-monitor[400000+15000]

and there are repeated messages of the following form in .xsession-errors:

(firefox:3473): GVFS-RemoteVolumeMonitor-WARNING **: invoking IsSupported() failed for remote volume monitor with dbus name org.gtk.Private.GduVolumeMonitor: org.freedesktop.DBus.Error.Spawn.ChildSignaled: Process /usr/libexec/gvfs-gdu-volume-monitor received signal 11
_gdu_device_changed: /dev/sda

(gdu-notification-daemon:3063): libgdu-WARNING **: unhandled property 'device-detection-time'

(gdu-notification-daemon:3063): libgdu-WARNING **: unhandled property 'device-presentation-hide'
_gdu_device_changed: /dev/sda

(gdu-notification-daemon:3063): libgdu-WARNING **: unhandled property 'device-detection-time'

(gdu-notification-daemon:3063): libgdu-WARNING **: unhandled property 'device-presentation-hide'


Version-Release number of selected component (if applicable):
gvfs-1.2.2-3.fc11.x86_64
gnome-disk-utility-libs-0.3-0.4.20090412git.fc11.x86_64
gnome-disk-utility-0.3-0.4.20090412git.fc11.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Seemingly on login.
Comment 1 Matthias Clasen 2009-04-17 16:59:35 EDT
Does gvfs-gdu-volume-monitor also segfault when you start it manually ?
Can you get a stacktrace ?
Comment 2 James 2009-04-17 17:33:14 EDT
Created attachment 340095 [details]
gdb transcript for gvfs-gdu-volume-monitor

It segfaults when started by hand. I've attached the transcript from gdb.
Comment 3 Matthias Clasen 2009-04-17 18:20:42 EDT
Duplicate of bug 496228 ?
Please update gnome-disk-utility and try again.
Comment 4 David Zeuthen 2009-04-17 18:41:56 EDT
(In reply to comment #3)
> Duplicate of bug 496228 ?

Affirmative. Also, the reporter didn't reboot after applying the updates

(process:29245): libgdu-WARNING **: unhandled property 'device-detection-time'
(process:29245): libgdu-WARNING **: unhandled property 'device-presentation-hide'
_gdu_device_new_from_object_path: /dev/sda1

> Please update gnome-disk-utility and try again.

*** This bug has been marked as a duplicate of bug 496228 ***

Note You need to log in before you can comment on or make changes to this bug.