Bug 496335 - [kms] native resolution not used when kms is enabled (i915)
[kms] native resolution not used when kms is enabled (i915)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
12
All Linux
low Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-17 17:24 EDT by Need Real Name
Modified: 2009-11-12 11:36 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-12 11:36:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the xorg log for with a normal boot (modesetting). I hold the power button when the machine does not respond. (39.57 KB, text/plain)
2009-05-04 14:52 EDT, Need Real Name
no flags Details
the xorg log with nomodeset as a kernel boot parameter. (39.16 KB, text/plain)
2009-05-04 14:53 EDT, Need Real Name
no flags Details
lspci output (2.22 KB, text/plain)
2009-05-04 14:53 EDT, Need Real Name
no flags Details
my xorg.conf file (739 bytes, text/plain)
2009-05-04 14:55 EDT, Need Real Name
no flags Details
xorg log with modesetting (61.20 KB, text/plain)
2009-05-04 15:30 EDT, Need Real Name
no flags Details
xorg log with no modesetting (59.14 KB, text/plain)
2009-05-04 15:31 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2009-04-17 17:24:30 EDT
hw: http://www.smolts.org/client/show/pub_1f537efb-3ace-44a1-bef6-d3bd92eb4a08  
xorg: https://bugzilla.redhat.com/attachment.cgi?id=339892

kernel-2.6.29.1-46.fc11.x86_64 works fine with my screen. everything else switches to a low resolution for X itself. console while booting is correct.
s-c-d shows no useful resolutions.

This is frustrating since it used to work.
Comment 1 Need Real Name 2009-04-17 17:26:35 EDT
Oh and suspend resume is broken now too.
Comment 2 Need Real Name 2009-04-17 18:05:11 EDT
> Oh and suspend resume is broken now too.

Actually it's worse, switching VTs is broken. If I am lucky I get a terminal by continuously trying new VTs, but then everything freezes. If I keep trying more, I might see a _ cursor flashing ridiculously fast, so fast it's almost not flashing. Ctrl+Alt+Del does not response.

Upping severity since this is now a crash bug.
Comment 3 Chuck Ebbert 2009-04-18 00:24:39 EDT
Is this report against 2.6.29.1-85?

Can you try -97 from koji?
Comment 4 Need Real Name 2009-04-18 04:32:51 EDT
This is a report against everything after 46.fc11.x86_64, up to and including kernel-2.6.29.1-70.fc11.x86_64.

I will try 97 now.
Comment 5 Need Real Name 2009-04-18 04:47:33 EDT
I booted into 97, and got the wrong resolution again, same as above (i.e. correct at one point during boot).

Tried switching vts - freeze. No escape.

Reboot 1 - Freeze when X starts.
Reboot 2 - Freeze when X starts.

Gone back to 46 for now.
Comment 6 Need Real Name 2009-04-18 05:30:24 EDT
My screen's native resolution is 1680x1050.
Setting xorg.conf to this shows "no mode of this name".

Perhaps relevant?
Comment 7 Need Real Name 2009-04-22 17:33:51 EDT
Still broken in kernel-2.6.29.1-100.fc11.x86_64.

Do you need logs or anything?
Comment 8 Need Real Name 2009-04-29 14:36:37 EDT
I realise you're busy, but I'm sitting here with a pretty much broken Fedora install and I've not heard anything.

Do you expect the i915 will work before Fedora 11 reaches final?

It seems strange that I can switch vts, but not run ctrl+alt+del or even use the vts.

-46 doesn't crash my system, but the resolution is stretched making it awkward for anything graphical. No looking at photos, etc.
Comment 9 Need Real Name 2009-05-04 13:30:03 EDT
kernel-2.6.29.1-111.fc11.x86_64 is also broken.
Comment 10 Kevin Fenzi 2009-05-04 14:21:15 EDT
How about attaching your /var/log/Xorg.0.log and dmesg from the 111 case? 

I have a eee900 here with i915 thats working fine.
Comment 11 Need Real Name 2009-05-04 14:27:44 EDT
Sure, it's in the first comment:
 https://bugzilla.redhat.com/attachment.cgi?id=339892
Comment 12 Kevin Fenzi 2009-05-04 14:38:04 EDT
For the -111 kernel and xorg-x11-drv-intel-2.7.0-2.fc11 case? 
That seems to be the -70 kernel and 2.6.99 intel driver.
Comment 13 Need Real Name 2009-05-04 14:44:02 EDT
(In reply to comment #12)
> For the -111 kernel and xorg-x11-drv-intel-2.7.0-2.fc11 case? 
> That seems to be the -70 kernel and 2.6.99 intel driver.  

Yes that's for an older kernel.

I'll upload two new xorg log files.
Comment 14 Need Real Name 2009-05-04 14:52:08 EDT
Created attachment 342351 [details]
the xorg log for with a normal boot (modesetting). I hold the power button when the machine does not respond.
Comment 15 Need Real Name 2009-05-04 14:53:19 EDT
Created attachment 342352 [details]
the xorg log with nomodeset as a kernel boot parameter.

This at least doesn't crash the box, but I get the wrong 1280x1024 resolution in X, despite configuring 1400x1050. Colour depth is 16 if that helps.
Comment 16 Need Real Name 2009-05-04 14:53:52 EDT
Created attachment 342353 [details]
lspci output
Comment 17 Need Real Name 2009-05-04 14:55:24 EDT
Created attachment 342354 [details]
my xorg.conf file

Initially generated by s-c-d, but amended to use 16 colours to see if that helped.

I notice "driver vesa". Will try changing to intel.
Comment 18 Need Real Name 2009-05-04 15:03:27 EDT
Changing "driver vesa" to "driver intel" gives me native resolution!

But only if I boot with nomodeset.

If I boot normally, I get X in 1024 x 768 despite the framebuffer using the native resolution.
Comment 19 Kevin Fenzi 2009-05-04 15:06:05 EDT
So, from that I assume you have a /etc/X11/xorg.conf? 
does it work if you move/remove that file and boot without it?
Comment 20 Need Real Name 2009-05-04 15:10:12 EDT
nomodeset + xorg.conf file = X native resolution
modeset + xorg.conf file = X low resolution

and if I remember correctly (I can retest if you want):

nomodeset + no xorg.conf = X low resoltuion
modeset + no xorg.conf = crash
Comment 21 Need Real Name 2009-05-04 15:13:37 EDT
Correction:
> nomodeset + no xorg.conf = X low resoltuion

nomodeset + no xorg.conf = X native resolution

This is new. Good.
Comment 22 Need Real Name 2009-05-04 15:18:22 EDT
To re-summarise:

nomodeset + xorg.conf file = X native resolution
modeset   + xorg.conf file = X low resolution

nomodeset + no xorg.conf file = X native resolution
modeset   + no xorg.conf file = X low resolution

It looks like the intel driver is skipping over my screen's resolution:

(II) intel(0): Printing probed modes for output DVI1
(II) intel(0): Modeline "1680x1050"x60.0  146.25  1680 1784 1960 2240  1050 1053 1059 1089 -hsync +vsync (65.3 kHz)
(II) intel(0): Modeline "1280x1024"x75.0  135.00  1280 1296 1440 1688  1024 1025 1028 1066 +hsync +vsync (80.0 kHz)
Comment 23 Adam Williamson 2009-05-04 15:29:23 EDT
I am confused. In both of the logs you posted, the driver in use is vesa, not intel. In this case no modesetting would be used, there's no modesetting for the vesa driver (AFAIK).

Can you provide Xorg.0.logs from the case with no xorg.conf file?
Comment 24 Need Real Name 2009-05-04 15:30:35 EDT
Created attachment 342361 [details]
xorg log with modesetting
Comment 25 Need Real Name 2009-05-04 15:31:41 EDT
Created attachment 342362 [details]
xorg log with no modesetting
Comment 26 Need Real Name 2009-05-04 15:32:48 EDT
Here are the logs with no xorg.conf file.
Comment 27 Adam Williamson 2009-05-04 16:40:36 EDT
looks like enough information there for kristian to figure out what's wrong. thanks. correcting summary.
Comment 28 Bug Zapper 2009-06-09 10:02:20 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 30 Need Real Name 2009-11-08 10:07:30 EST
WFM
Comment 31 Adam Jackson 2009-11-12 11:36:25 EST
I'm assuming comment #30 means "it works now".  Closing on that basis, please reopen if I'm wrong.

Note You need to log in before you can comment on or make changes to this bug.