Bug 496339 - FormatCreateError: invalid device specification
FormatCreateError: invalid device specification
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-17 17:48 EDT by Mathieu Bridon
Modified: 2009-06-09 10:12 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-09 10:12:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mathieu Bridon 2009-04-17 17:48:05 EDT
Description of problem:
I tried to install Fedora 11 snapshot from the liveCD.

I had the following partitionning scheme before that:
/dev/sda1  /boot               100MB
/dev/sda2  /                 10240MB
/dev/sda3  /home             20480MB
/dev/sda5  swap               1024MB
/dev/sda6  /var/lib/libvirt  10240MB
/dev/sda7  /var/lib/mock     10240MB

Everything was ext3.

In anaconda, I deleted all partitions and chose the following partitionning scheme:
/dev/sda1  /boot               200MB
/dev/sda2  /                 20480MB
/dev/sda3  /home             30720MB

I chose ext4 (except for /boot which was ext3)

I then validated and accepted when I was said that it would lose all data currently on the disk.

Then, a lot of DeviceKit error popups showed up, and it stopped when Anaconda issued a traceback.

As Murphy predicted, Anaconda succeeded in erasing my previous partitions but failed creating the new ones, so I'm now a a live system I can't install :)

You can find everything I could gather at the following URL:
http://bochecha.fedorapeople.org/f11

The .log files come from /tmp.

(there were also DeviceKit popups for /var/lib/libvirt and /var/lib/mock, so the partitions it says can't be mounted must be the ones I had before installing)

Note that each popup appeared around 5 times.

Version-Release number of selected component (if applicable):
anaconda-11.5.0.42-1.x86_64
anaconda-yum-plugins-1.0-4.fc11.noarch
DeviceKit-disks-004-0.5.20090408git.fc11.x86_64
DeviceKit-power-008-0.1.20090401git.fc11.x86_64
DeviceKit-003-1.x86_64

I'm not sure if the bug is in Anaconda or DeviceKit. As I said, there were first a lot of DeviceKit popups and then the Anaconda traceback showed up, as if the DeviceKit issues had lead to the Anaconda error.
Comment 1 Mathieu Bridon 2009-04-17 17:55:54 EDT
I just tried again, creating the same new partitionning scheme (but obviously not from the same previous one as it was nuked at first attempt).

I got the same kind of DeviceKit error popups, this time for:
- 210MB filesystem
- 21GB filesystem
(several times each)

However, Anaconda did not crash and I'm proceeding the installation, so those might be two different issues.
Comment 2 Jeremy Katz 2009-04-22 16:11:17 EDT
The devicekit popups should be fixed post-snapshot (they were a gvfs/devkit-disks bug).
Comment 3 Mathieu Bridon 2009-04-22 17:15:40 EDT
Great !

So that was unrelated to the anaconda crash right ?
Comment 4 Andy Lindeberg 2009-06-08 15:49:54 EDT
F11 Final is being released tomorrow. Can you test with that and let us know if the problem has been fixed?
Comment 5 Mathieu Bridon 2009-06-08 15:57:48 EDT
Well, I'll try, but as I said in comment #1, it only happened the first time, when it tried to erase my F10 partitions. Trying again with the same ISO worked the second time.

To try it again, I'd have to reinstall F10 over my current F11 with the same partitionning I had and then reinstall F11 over it. Not sure when I'll have enough time to do that (and the mandatory backups of all my data)... :-/
Comment 6 Bug Zapper 2009-06-09 10:02:43 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Andy Lindeberg 2009-06-09 10:12:50 EDT
If it's going to be a hassle, don't worry about retesting. We haven't seen this in any of our own testing, so I'm going to close this as RAWHIDE for now. If you happen to run into it again, feel free to reopen.

Note You need to log in before you can comment on or make changes to this bug.