Bug 496345 - Anaconda fails to bring up network interface
Anaconda fails to bring up network interface
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-17 18:22 EDT by Peter McNabb
Modified: 2009-04-20 09:58 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-20 09:58:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter McNabb 2009-04-17 18:22:25 EDT
Description of problem:
During kvm guest installation of rawhide on Fedora 10 host, anaconda cannot bring up the eth0 interface. It fails (with the error message below) for both DHCP and Static configurations. I have tried both "Generic 2.6 kernel" (which provides a Realtek 8139 card to the VM) and "Fedora 10" (uses VirtIO drivers). The VM network is bridged with the host's network.

However, at that point of the installation, if I switch to console #2, I can run "dhclient eth0", immediately get an address from a DHCP server, and ping a host on the Internet. This verifies that the problem is with anaconda (or possibly NetworkManager).

Version-Release number of selected component (if applicable):
anaconda 11.5.0.44
boot.iso from 4/16/09

Steps to Reproduce:
1. Use virt-manager on Fedora 10 to create a new guest
2. Use boot.iso as installation media
3. Try to get past the network setup screen in anaconda
  
Actual results:
An "Error Configuring Network" dialog popups with the message: "An error occurred trying to bring up the eth0 network interface.

Expected results:
Network should be configured.

Additional info:
On console #4, I see the following two messages several times:
nm-system-settings:     ifcfg-rh:       parsing /etc/sysconfig/network-scripts/ifcfg-eth0.new
nm-system-settings:     ifcfg-rh:       error: Couldn't parse file '/etc/sysconfig/network-scripts/ifcfg-eth0.new'

and then the following two messages:

nm-system-settings:     ifcfg-rh:       updating /etc/sysconfig/network-scripts/
ifcfg-eth0
nm-system-settings:     update: assertion `context != NULL' failed
Comment 1 Chris Lumens 2009-04-20 09:58:56 EDT
This was fixed with a new build of NetworkManager.

Note You need to log in before you can comment on or make changes to this bug.