Bug 496363 - anaconda refuses to mount encrypted file systems
anaconda refuses to mount encrypted file systems
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-18 00:35 EDT by Clyde E. Kunkel
Modified: 2009-05-19 16:20 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-19 16:20:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clyde E. Kunkel 2009-04-18 00:35:58 EDT
Description of problem:
During clean install of rawhide 20090417 using custom partitioning, specified that some encryted LVs be mounted on /mnt/...., but during first boot passwords were not prompted, LVs not mounted and directories in /mnt did not exist

Version-Release number of selected component (if applicable):
11.5.0.45

How reproducible:
each time

Steps to Reproduce:
1. boot.iso, askmethod
2. select custom partitioning
3. edit encrypted LVs requesting mount on /mnt/...
  
Actual results:
Looked good, but on first boot and subsequent, they were mot mounted, nor did directories exist in /mnt

Expected results:
mounted encrypted partitions (LVs)

Additional info:
Comment 1 Clyde E. Kunkel 2009-04-19 17:08:29 EDT
In 11.5.0.46, you must first custom mount another LV in a VG, then custom mount the encrypted LV, otherwise anaconda ignores the mount point you specify.  This may have been the case in .45, I didn't think to revisit a VG with that version.
Comment 2 Mike Wolf 2009-04-20 22:39:25 EDT
I think I'm experiencing the same bug, (rawhide 20090420) though through a slightly different method.  I had a working installation on a test machine where the VG on /dev/sda2 was encrypted, and I had created another encrypted ext4 partition directly at /dev/sda3 which was mounted as /home.  Then I reinstalled...

I was able to remount everything except the encrypted ext4 partition on /dev/sda3.  This was the only partition/volume that I chose not to format, since I wouldn't be formatting that partition if it were a system I used every day.

I later tried recreating this scenario without any encrypted partitions.  Without encryption, /dev/sda3 mounted to /home with no problem.
Comment 3 Clyde E. Kunkel 2009-04-22 18:19:12 EDT
pre-existing encrypted partitions still not mountable in anaconda 11.5.0.47 unless you first edit another LV in the VG.
Comment 4 Clyde E. Kunkel 2009-05-03 14:55:33 EDT
You still must edit an encrypted file system two times in a row to get anaconda to record the mount point.  .48 version.
Comment 5 Clyde E. Kunkel 2009-05-08 11:44:50 EDT
Still a problem in version .50.  Also, 499828 may have some relationship.
Comment 6 David Lehman 2009-05-08 12:00:42 EDT
(In reply to comment #3)
> pre-existing encrypted partitions still not mountable in anaconda 11.5.0.47
> unless you first edit another LV in the VG.  

Have you seen this with partitions also or only with LVs?
Comment 8 Clyde E. Kunkel 2009-05-08 14:42:34 EDT
Not with non-encypted partitions, I only have encrypted LVs.  Give me a couple hours and I'll build a test case.
Comment 9 David Lehman 2009-05-08 14:59:25 EDT
Don't spend the time unless you want to -- encrypted partitions have been addressed already and should work just fine. It was your use of the word "partitions" in comment #3 that made me wonder if you were seeing it with partitions or just using terms loosely.
Comment 10 Clyde E. Kunkel 2009-05-08 15:41:32 EDT
Didn't see #9 in time, so went ahead and built the test caser and encrypted partitions edit the first time.

I will be more careful about describing "partitions" and "LVs."  Thanks for pointing this out.
Comment 11 David Lehman 2009-05-11 14:55:57 EDT
Fix will be in anaconda-11.5.0.52-1. Thanks for the report.
Comment 12 Clyde E. Kunkel 2009-05-14 14:23:41 EDT
with anaconda .52, the mount point stays in the dialogue after hitting ok, but then after hitting the next ok to go back to the custom partitioning screen, traceback: "luks object has no attribute."  Auto bz said 499828 had already been submitted, traceback is there.
Comment 13 Clyde E. Kunkel 2009-05-19 16:20:49 EDT
Working in .53.  Closing.

Note You need to log in before you can comment on or make changes to this bug.