Bug 496365 - [FEAT]: QEMU: Add more information to SMBIOS
[FEAT]: QEMU: Add more information to SMBIOS
Status: CLOSED DUPLICATE of bug 495844
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Tim Burke
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-18 02:10 EDT by Yaniv Kaul
Modified: 2013-07-03 21:19 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-27 10:45:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yaniv Kaul 2009-04-18 02:10:28 EDT
Description of problem:
http://svn.savannah.gnu.org/viewvc/?view=rev&root=qemu&revision=7163 implemented more SMBIOS information:
 -smbios type=0[,vendor=str][,version=str][,date=str][,release=%d.%d]
 -smbios type=1[,manufacturer=str][,product=str][,version=str][,serial=str]
              [,uuid=$(uuidgen)][,sku=str][,family=str]

I wonder how much of this we need:
1. For special applications that look at those fields(P2V comes to mind - some HP apps need it - we know that already)
2. For our own use (the tools within the guest can make use of this information, for example, obtain underlying KVM version
3. I'm pretty sure this is NOT needed for SVVP - at least not with WLK 1.2 - but may be with future versions - 1.4.

I think we should see that we can live without it for RHEV-1.0, and then postpone it with no regrets to future releases.

Lastly, this is on KVM for merge purposes, but once it's in the code, BZs should be opened for VDSM and RHEV-M to support it.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Yaniv Kaul 2009-04-26 07:59:34 EDT
Related to https://bugzilla.redhat.com/show_bug.cgi?id=495842 (KVM SVVP: The SMBIOS HCT failed the SVVP testing when install windows 2008 on kvm)
Comment 2 Dor Laor 2009-04-27 10:45:06 EDT

*** This bug has been marked as a duplicate of bug 495844 ***

Note You need to log in before you can comment on or make changes to this bug.