Bug 496366 - KMS + rv280 results in black screen
KMS + rv280 results in black screen
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-18 03:23 EDT by Bruno Wolff III
Modified: 2009-10-10 14:53 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-10 14:53:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log from a successful boot (57.65 KB, text/plain)
2009-04-18 03:23 EDT, Bruno Wolff III
no flags Details
Xorg.0.log from modeset boot (57.69 KB, text/plain)
2009-04-28 23:17 EDT, Bruno Wolff III
no flags Details

  None (edit)
Description Bruno Wolff III 2009-04-18 03:23:26 EDT
Created attachment 340132 [details]
Xorg.0.log from a successful boot

Description of problem:
At about the point in the boot sequence where I would expect the modeset switch to occur the screen goes black. The boot process doesn't complete. (Though I have encrypted partitions so I would need to be able to enter some data in order to finish the boot, so it's possible that the boot process is continuing, but that I can't tell.) When I use the nomodeset parameter the boot process works as expected.

Version-Release number of selected component (if applicable):
kernel-2.6.29.1-97.fc11.i686.PAE
xorg-x11-drv-ati-6.12.2-4.fc11.i586
libdrm-2.4.6-6.fc11.i586
mesa--7.5-0.11.fc11

How reproducible:
100%

Steps to Reproduce:
1. Boot with modeset
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Bruno Wolff III 2009-04-21 10:59:17 EDT
I retested this with kernel 2.6.29.1-103.fc11.i686.PAE and I still get a black screen (with signal) early in the boot process if I boot with modeset instead of nomodeset.
Comment 2 Bruno Wolff III 2009-04-28 19:55:45 EDT
Today I tried entering my luks password blind a couple of times and going away for 10 or 15 minutes to do some other stuff. When I came back I had a normal working gnome session. I tried switching to a vt and while a switch occured, the graphics in that mode were messed up. I had specs of white on a mostly dark screen. When I typed stuff, the specs changed. I switched back to X and my gnome session is working OK.
I currently have installed:
xorg-x11-drv-ati-6.12.2-9.fc11
mesa-7.5-0.13.fc11
xorg-x11-server-1.6.1-9.fc11
Comment 3 Bruno Wolff III 2009-04-28 23:11:45 EDT
Thinking about it I thought it might also be useful to mention that I do not use the quiet or rhgb kernel parameters when booting. For testing I was using the 2.6.29.1-111.fc11.i686.PAE kernel with the following parameters:
elevator=deadline modeset crashkernel=256M
Comment 4 Bruno Wolff III 2009-04-28 23:17:39 EDT
Created attachment 341691 [details]
Xorg.0.log from modeset boot
Comment 5 Bruno Wolff III 2009-05-05 11:10:04 EDT
I retested this with today's koji updates (xorg-x11-drv-ati-6.12.2-11.fc11, mesa-7.5-0.14.fc11 and kernel-PAE-2.6.29.2-128.fc11) and am still seeing the same symptoms.
Comment 6 Bug Zapper 2009-06-09 10:03:36 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Bruno Wolff III 2009-10-10 14:53:24 EDT
This is no longer happening in rawhide (F12).

Note You need to log in before you can comment on or make changes to this bug.