Bug 496403 - bash-completion: cd doesn't complete when both "a'b c/" and "a'b.c/" exist
bash-completion: cd doesn't complete when both "a'b c/" and "a'b.c/" exist
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bash-completion (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-18 13:54 EDT by Scott Tsai
Modified: 2010-07-01 14:59 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.2-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-22 16:28:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Tsai 2009-04-18 13:54:20 EDT
Description of problem:
When two directories named "a'b c/" and  "a'b.c/" (replace space with dot) exist, Tab-completion with the 'cd' builtin breaks. Tab-completion works if bash-completion is not installed.

Version-Release number of selected component (if applicable):
bash-completion-1.0-2.fc11.noarch
bash-4.0-6.fc11.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. mkdir "a'b c" "a'b.c"
2. cd a\'b.<Tab>

  
Actual results:
No output.

Expected results:
cd a\'b.c/

Additional info:
Comment 1 Ville Skyttä 2009-04-18 17:52:12 EDT
Works for me with bash 3.2-30 on F-10 so this is probably something bash 4 related.  It'll take some time until I can debug this with it.
Comment 2 Bug Zapper 2009-06-09 10:04:58 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Fedora Update System 2010-06-20 08:18:00 EDT
bash-completion-1.2-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/bash-completion-1.2-1.fc13
Comment 5 Fedora Update System 2010-07-01 14:59:38 EDT
bash-completion-1.2-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.