Bug 496406 - Anaconda barfs on bind mount in fstab
Anaconda barfs on bind mount in fstab
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
anaconda_trace_hash:a405b995736503229...
:
Depends On: 494992
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-18 14:29 EDT by Callum Lerwick
Modified: 2009-07-17 12:20 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 494992
Environment:
Last Closed: 2009-07-17 12:20:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (180.60 KB, text/plain)
2009-06-11 16:36 EDT, Chris Paulson-Ellis
no flags Details
Attached traceback automatically from anaconda. (167.57 KB, text/plain)
2009-06-14 22:27 EDT, Matthew
no flags Details
Attached traceback automatically from anaconda. (152.93 KB, text/plain)
2009-06-15 18:06 EDT, Eric Moret
no flags Details
Attached traceback automatically from anaconda. (155.29 KB, text/plain)
2009-07-15 13:22 EDT, Victor Gubin
no flags Details

  None (edit)
Description Callum Lerwick 2009-04-18 14:29:54 EDT
+++ This bug was initially created as a clone of Bug #494992 +++

Anaconda is harfing on a bind mount now. See bz #494992 for traceback.
Comment 1 David Lehman 2009-04-30 19:04:14 EDT
This should work correctly as of anaconda-11.5.0.48-1. Actually, the change I made there may have introduced a different bug which will be cleared up in anaconda-11.5.0.49-1, which has not yet been built.
Comment 2 Bug Zapper 2009-06-09 10:05:18 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Chris Paulson-Ellis 2009-06-11 16:36:11 EDT
Created attachment 347470 [details]
Attached traceback automatically from anaconda.
Comment 4 Chris Paulson-Ellis 2009-06-11 16:46:41 EDT
Anaconda decided to attach its traceback to this bug.

My problem was caused not by a bind mount fstab entry, but by a davfs2 entry like this one (details changed, but syntactically the same):

https://server.example.com:1234/share/ /mnt/share davfs noauto,user 0 0

I was upgrading from F10 to F11, via preupgrade.
Comment 5 Matthew 2009-06-14 22:27:31 EDT
Created attachment 347883 [details]
Attached traceback automatically from anaconda.
Comment 6 Eric Moret 2009-06-15 18:06:06 EDT
Created attachment 348018 [details]
Attached traceback automatically from anaconda.
Comment 7 Eric Moret 2009-06-15 18:15:07 EDT
Following an attempt to upgrade from Fedora 10 to Fedora 11 with preupgrade I saw an anaconda crash (See Commend #6) due to the following lines in my /etc/fstab

[...]
# Begining of the block added by the VMware software
.host:/                 /mnt/hgfs                 vmhgfs   defaults,ttl=5   0 0
# End of the block added by the VMware software
Comment 8 Matthew 2009-06-15 21:34:10 EDT
Same issue for me, just had to comment the .host:/ line in /etc/fstab and all was OK
Comment 9 David Lehman 2009-06-17 13:04:26 EDT
(In reply to comment #7)
> Following an attempt to upgrade from Fedora 10 to Fedora 11 with preupgrade I
> saw an anaconda crash (See Commend #6) due to the following lines in my
> /etc/fstab
> 
> [...]
> # Begining of the block added by the VMware software
> .host:/                 /mnt/hgfs                 vmhgfs   defaults,ttl=5   0 0
> # End of the block added by the VMware software  

This should be fixed by commit 2d1560fb8e92ff4a01ee8ba48069475e274fc954 to anaconda. The same commit should fix the failure with the davfs line as well.
Comment 10 Victor Gubin 2009-07-15 13:22:10 EDT
Created attachment 353855 [details]
Attached traceback automatically from anaconda.
Comment 11 Callum Lerwick 2009-07-16 12:57:38 EDT
Note that I stripped my fstab bare and had no further problems pre-upgrading to F11 some time ago. So I won't be doing any further testing of this bug. If you believe that it is fixed, feel free to close the bug.
Comment 12 David Lehman 2009-07-17 12:20:47 EDT
This bug should be completely resolved in anaconda-12.0-1. Please reopen if you find the issue persists.

Note You need to log in before you can comment on or make changes to this bug.