Bug 496407 - Internal system error when trying to update system
Internal system error when trying to update system
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
10
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-18 14:55 EDT by Shay Rossignol
Modified: 2014-01-21 18:09 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-12 17:23:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
same error in python 2.6 though (83.60 KB, image/png)
2009-05-23 10:01 EDT, beemer
no flags Details
An internal system error keeps re-occurring. (27.64 KB, image/png)
2009-06-30 13:24 EDT, Stephen Blessing
no flags Details

  None (edit)
Description Shay Rossignol 2009-04-18 14:55:13 EDT
Description of problem: Internal system error when refreshing package cache. Second time this happened after fresh install.


Version-Release number of selected component (if applicable):


How reproducible:
System --> Administration --> Update System; System Sources 

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Shay Rossignol 2009-04-18 14:56:25 EDT
Error Type: <type 'exceptions.TypeError'>
Error Value: rpmdb open failed
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 2316, in <module>
    main()
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 2312, in main
    backend = PackageKitYumBackend('', lock=True)
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 182, in __init__
    self.yumbase = PackageKitYumBase(self)
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 2255, in __init__
    self.repos.confirm_func = self._repo_gpg_confirm
  File : /usr/lib/python2.5/site-packages/yum/__init__.py, line 589, in <lambda>
    repos = property(fget=lambda self: self._getRepos(),
  File : /usr/lib/python2.5/site-packages/yum/__init__.py, line 395, in _getRepos
    self._getConfig() # touch the config class first
  File : /usr/lib/python2.5/site-packages/yum/__init__.py, line 192, in _getConfig
    self._conf = config.readMainConfig(startupconf)
  File : /usr/lib/python2.5/site-packages/yum/config.py, line 774, in readMainConfig
    yumvars['releasever'] = _getsysver(startupconf.installroot, startupconf.distroverpkg)
  File : /usr/lib/python2.5/site-packages/yum/config.py, line 844, in _getsysver
    idx = ts.dbMatch('provides', distroverpkg)
Comment 2 Shay Rossignol 2009-04-18 15:00:35 EDT
Error Type: <type 'exceptions.TypeError'>
Error Value: rpmdb open failed
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 2316, in <module>
    main()
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 2312, in main
    backend = PackageKitYumBackend('', lock=True)
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 182, in __init__
    self.yumbase = PackageKitYumBase(self)
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 2255, in __init__
    self.repos.confirm_func = self._repo_gpg_confirm
  File : /usr/lib/python2.5/site-packages/yum/__init__.py, line 589, in <lambda>
    repos = property(fget=lambda self: self._getRepos(),
  File : /usr/lib/python2.5/site-packages/yum/__init__.py, line 395, in _getRepos
    self._getConfig() # touch the config class first
  File : /usr/lib/python2.5/site-packages/yum/__init__.py, line 192, in _getConfig
    self._conf = config.readMainConfig(startupconf)
  File : /usr/lib/python2.5/site-packages/yum/config.py, line 774, in readMainConfig
    yumvars['releasever'] = _getsysver(startupconf.installroot, startupconf.distroverpkg)
  File : /usr/lib/python2.5/site-packages/yum/config.py, line 844, in _getsysver
    idx = ts.dbMatch('provides', distroverpkg)
Comment 3 beemer 2009-05-23 10:01:18 EDT
Created attachment 345196 [details]
same error in python 2.6 though

Same problem on my system. Freshly installed F11 and at the first system update get this error. The errors are exactly the same however I seem to have got a later version of python, so attaching a screenshot - so you have the required info.
Comment 4 Stephen Blessing 2009-06-26 15:25:16 EDT
I noticed my system time and date had changed to September 1994 and a time in the evening. I recently updated my system from FC10 to FC11 and then ran the yum update command on 6-25-09 and now I get the internal system error that says, "more than one preupgrade package installed".
Comment 5 Stephen Blessing 2009-06-30 13:24:51 EDT
Created attachment 349977 [details]
An internal system error keeps re-occurring.
Comment 6 seth vidal 2009-07-01 15:14:19 EDT
Sounds like there is a lot going on (and wrong) on this system.

Have you been experiencing any other random events? Segfaults?
Comment 7 Stephen Blessing 2009-07-01 18:10:57 EDT
I only get the internal system error that says, "more than one preupgrade package installed" randomly appearing since the last couple updates -- no other problems. This is a dual-boot system (WinXP/FC Linux), with multiple Fedora Core Linux OS's (FC8, FC10, & FC11).
Comment 8 Gerardo Banaag 2009-09-16 05:06:08 EDT
Got this repeating "Internal System Error" message. Below are the details.

++++++++++++++++++++++++++++++++++++++++++++
Traceback (most recent call last):
  File "/usr/share/PackageKit/helpers/yum/yumBackend.py", line 2461, in _check_init
    self.yumbase.repos.doSetup()
  File "/usr/lib/python2.6/site-packages/yum/repos.py", line 79, in doSetup
    self.ayum.plugins.run('postreposetup')
  File "/usr/lib/python2.6/site-packages/yum/plugins.py", line 179, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/rpm-warm-cache.py", line 32, in postreposetup_hook
    cmd = commands[0]
TypeError: 'NoneType' object is unsubscriptable
+++++++++++++++++++++++++++++++++++++++++++++
Comment 9 Tim Lauridsen 2009-09-16 09:19:56 EDT
(In reply to comment #8)
> Got this repeating "Internal System Error" message. Below are the details.
> 
> ++++++++++++++++++++++++++++++++++++++++++++
> Traceback (most recent call last):
>   File "/usr/share/PackageKit/helpers/yum/yumBackend.py", line 2461, in
> _check_init
>     self.yumbase.repos.doSetup()
>   File "/usr/lib/python2.6/site-packages/yum/repos.py", line 79, in doSetup
>     self.ayum.plugins.run('postreposetup')
>   File "/usr/lib/python2.6/site-packages/yum/plugins.py", line 179, in run
>     func(conduitcls(self, self.base, conf, **kwargs))
>   File "/usr/lib/yum-plugins/rpm-warm-cache.py", line 32, in postreposetup_hook
>     cmd = commands[0]
> TypeError: 'NoneType' object is unsubscriptable
> +++++++++++++++++++++++++++++++++++++++++++++  

This bug is another issue, it is because the current rpm-warm-cache don't play nice with PK, if you don't need it then remove it

yum remove yum-plugin-rpm-warm-cache

the issue is fixed in upstream yum-utils and in rawhide, but can't be released in F10.
Comment 10 Gerardo Banaag 2009-09-16 20:27:02 EDT
I have done your suggestion as below.

yum remove yum-plugin-rpm-warm-cache

Seems to be working fine now. Error message not popping as of now.
Thanks Tim.

Note You need to log in before you can comment on or make changes to this bug.