Bug 49641 - up2date should report all operating system errors
up2date should report all operating system errors
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-22 12:57 EDT by filos2
Modified: 2015-01-07 18:48 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-15 16:45:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description filos2 2001-07-22 12:57:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.3-12 i686)

Description of problem:
When an installation fails due to an operating system error, up2date
doesn't report
what the error was: it just dies.

How reproducible:
Always

Steps to Reproduce:
1. chattr +i /bin/login (this makes the system more secure)
2. run up2date and upgrade to util-linux-2.10s-13.7i386.rpm

	

Actual Results:  up2date dies with no indication why

Expected Results:  up2date should have reported the operating system error
message:
"/bin/login could not be renamed to /bin/login-RPMDELETE"

Additional info:
Comment 1 Adrian Likins 2001-08-02 17:03:48 EDT
I'll take a look.

up2date should be made to at least reported that there was a 
an rpm error, and what that error was if possible. 

This could get interesting...
Comment 2 Adrian Likins 2002-05-15 16:45:40 EDT
current versions (7.3..) of the client should be better about this. The
librpm error reporting was improved, and up2date was modified to
make use of the extra info.
Comment 3 Josef Komenda 2002-07-16 11:25:06 EDT
Latest version messages errors to user. Closing

Note You need to log in before you can comment on or make changes to this bug.