This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 496411 - error after choosing 'use free space'
error after choosing 'use free space'
Status: CLOSED DUPLICATE of bug 495433
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:5af1f729feb08ceca...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-18 15:18 EDT by Sven Lankes
Modified: 2010-05-02 10:15 EDT (History)
29 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-20 10:38:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (183.87 KB, text/plain)
2009-04-18 15:18 EDT, Sven Lankes
no flags Details
Attached traceback automatically from anaconda. (46.20 KB, text/plain)
2009-06-04 07:43 EDT, agente2012
no flags Details
Attached traceback automatically from anaconda. (116.36 KB, text/plain)
2009-06-04 09:00 EDT, agente2012
no flags Details
Attached traceback automatically from anaconda. (222.37 KB, text/plain)
2009-06-06 13:02 EDT, Graeme Hilton
no flags Details
Attached traceback automatically from anaconda. (195.99 KB, text/plain)
2009-06-11 03:41 EDT, aj
no flags Details
Attached traceback automatically from anaconda. (326.68 KB, text/plain)
2009-06-11 03:46 EDT, aj
no flags Details
Attached traceback automatically from anaconda. (97.43 KB, text/plain)
2009-06-11 17:34 EDT, Michael St. Laurent
no flags Details
Attached traceback automatically from anaconda. (417.67 KB, text/plain)
2009-06-13 23:59 EDT, vmusman
no flags Details
Attached traceback automatically from anaconda. (563.70 KB, text/plain)
2009-06-14 00:02 EDT, vmusman
no flags Details
Attached traceback automatically from anaconda. (154.87 KB, text/plain)
2009-06-14 02:19 EDT, vmusman
no flags Details
Attached traceback automatically from anaconda. (107.46 KB, text/plain)
2009-07-09 14:58 EDT, Elder Marco
no flags Details
Attached traceback automatically from anaconda. (177.93 KB, text/plain)
2009-07-16 22:35 EDT, bugchaser
no flags Details
Attached traceback automatically from anaconda. (116.00 KB, text/plain)
2009-07-25 07:32 EDT, redlabour
no flags Details
Attached traceback automatically from anaconda. (108.04 KB, text/plain)
2009-07-27 20:50 EDT, Andoni Martín
no flags Details
Attached traceback automatically from anaconda. (362.13 KB, text/plain)
2009-07-28 23:45 EDT, bugchaser
no flags Details
Attached traceback automatically from anaconda. (278.55 KB, text/plain)
2009-07-30 16:10 EDT, Juan Carlos
no flags Details
Attached traceback automatically from anaconda. (197.73 KB, text/plain)
2009-08-11 14:37 EDT, Eric Sandeen
no flags Details
Attached traceback automatically from anaconda. (114.06 KB, text/plain)
2009-09-10 12:04 EDT, Eduardo
no flags Details
Attached traceback automatically from anaconda. (116.12 KB, text/plain)
2009-09-12 11:42 EDT, Bob
no flags Details
Attached traceback automatically from anaconda. (210.24 KB, text/plain)
2009-09-12 13:29 EDT, Bob
no flags Details
Attached traceback automatically from anaconda. (117.36 KB, text/plain)
2009-09-15 21:54 EDT, Bob Dietrich
no flags Details
Attached traceback automatically from anaconda. (137.70 KB, text/plain)
2009-09-16 11:38 EDT, Rahul Anand
no flags Details
Attached traceback automatically from anaconda. (84.66 KB, text/plain)
2009-09-16 14:51 EDT, Sebastian Day
no flags Details
Attached traceback automatically from anaconda. (120.96 KB, text/plain)
2009-09-21 07:10 EDT, sauvage
no flags Details
Attached traceback automatically from anaconda. (120.99 KB, text/plain)
2009-10-05 13:27 EDT, sauvage
no flags Details
Attached traceback automatically from anaconda. (8.90 MB, text/plain)
2009-10-16 18:33 EDT, Boyd
no flags Details
Attached traceback automatically from anaconda. (101.08 KB, text/plain)
2009-10-16 18:41 EDT, Boyd
no flags Details
Attached traceback automatically from anaconda. (105.71 KB, text/plain)
2009-10-24 11:45 EDT, sauvage
no flags Details
Attached traceback automatically from anaconda. (157.62 KB, text/plain)
2009-10-24 18:40 EDT, Darr247
no flags Details
Attached traceback automatically from anaconda. (82.15 KB, text/plain)
2009-10-24 18:53 EDT, Darr247
no flags Details
Attached traceback automatically from anaconda. (59.15 KB, text/plain)
2009-10-24 19:43 EDT, Darr247
no flags Details
Attached traceback automatically from anaconda. (153.60 KB, text/plain)
2009-10-28 00:29 EDT, Alexander
no flags Details
Attached traceback automatically from anaconda. (216.15 KB, text/plain)
2009-10-28 00:40 EDT, Alexander
no flags Details
Attached traceback automatically from anaconda. (86.18 KB, text/plain)
2009-11-01 11:45 EST, zafasach
no flags Details
Attached traceback automatically from anaconda. (115.00 KB, text/plain)
2009-11-13 10:57 EST, kruvalig
no flags Details
Attached traceback automatically from anaconda. (97.16 KB, text/plain)
2009-11-14 14:10 EST, AG
no flags Details
Attached traceback automatically from anaconda. (88.60 KB, text/plain)
2009-11-16 10:34 EST, eduardo
no flags Details
Attached traceback automatically from anaconda. (98.21 KB, text/plain)
2009-11-16 11:55 EST, eduardo
no flags Details
Attached traceback automatically from anaconda. (283.13 KB, text/plain)
2010-02-08 19:07 EST, Val
no flags Details
Attached traceback automatically from anaconda. (112.81 KB, text/plain)
2010-04-20 00:02 EDT, vivek
no flags Details
Attached traceback automatically from anaconda. (102.12 KB, text/plain)
2010-05-02 10:15 EDT, Millind Nagmoti
no flags Details

  None (edit)
Description Sven Lankes 2009-04-18 15:18:49 EDT
The following was filed automatically by anaconda:
anaconda None exception report
Traceback (most recent call first):
  File "/usr/lib/python2.6/site-packages/parted/geometry.py", line 128, in intersect
    return Geometry(PedGeometry=self.__geometry.intersect(b.getPedGeometry()))
  File "/usr/lib/anaconda/storage/partitioning.py", line 487, in getBestFreeSpaceRegion
    free_geom = extended.geometry.intersect(_range)
  File "/usr/lib/anaconda/storage/partitioning.py", line 697, in allocatePartitions
    boot=_part.req_bootable)
  File "/usr/lib/anaconda/storage/partitioning.py", line 562, in doPartitioning
    allocatePartitions(disks, partitions)
  File "/usr/lib/anaconda/storage/partitioning.py", line 186, in doAutoPartition
    exclusiveDisks=anaconda.id.storage.clearPartDisks)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1323, in nextClicked
    self.anaconda.dispatch.gotoNext()
CreateException: Error opening /dev/sdc: No medium found
Comment 1 Sven Lankes 2009-04-18 15:18:57 EDT
Created attachment 340172 [details]
Attached traceback automatically from anaconda.
Comment 2 Sven Lankes 2009-04-18 15:28:01 EDT
I was using the Snap1-i686 LiveCD to try to install to the HDD of a fresh Asus EEEBox (B202).

The partitioning looks like this:

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1        5222    41945683+   7  HPFS/NTFS
/dev/sda2            5223        5607     3088384   1b  Hidden W95 FAT32
Partition 2 does not end on cylinder boundary.
/dev/sda3            5607       19458   111254528    f  W95 Ext'd (LBA)

There used to be a /dev/sda5 (inside the extended sda3) but I deleted that (from Windows) to be able to install F11.

I started anaconda from the livecd, choose "use free space" and "review and modify existing layout" and got the above error.

I have now deleted /dev/sda3 and now the installation seems to be working.
Comment 3 Chris Lumens 2009-04-20 10:38:20 EDT

*** This bug has been marked as a duplicate of bug 495433 ***
Comment 4 agente2012 2009-06-04 07:43:23 EDT
Created attachment 346519 [details]
Attached traceback automatically from anaconda.
Comment 5 agente2012 2009-06-04 09:00:20 EDT
Created attachment 346529 [details]
Attached traceback automatically from anaconda.
Comment 6 Graeme Hilton 2009-06-06 13:02:02 EDT
Created attachment 346756 [details]
Attached traceback automatically from anaconda.
Comment 7 aj 2009-06-11 03:41:40 EDT
Created attachment 347349 [details]
Attached traceback automatically from anaconda.
Comment 8 aj 2009-06-11 03:46:48 EDT
Created attachment 347350 [details]
Attached traceback automatically from anaconda.
Comment 9 Michael St. Laurent 2009-06-11 17:34:02 EDT
Created attachment 347482 [details]
Attached traceback automatically from anaconda.
Comment 10 Michael St. Laurent 2009-06-11 18:00:12 EDT
On my system this bug seems to have been related to the presence of USB storage devices.  I had a USB hub plugged in that would accept the memory cards such as those found in cameras, etc.  Once I unplugged this the install was able to proceed.
Comment 11 vmusman 2009-06-13 23:59:39 EDT
Created attachment 347796 [details]
Attached traceback automatically from anaconda.
Comment 12 vmusman 2009-06-14 00:02:22 EDT
Created attachment 347797 [details]
Attached traceback automatically from anaconda.
Comment 13 vmusman 2009-06-14 02:19:37 EDT
Created attachment 347800 [details]
Attached traceback automatically from anaconda.
Comment 14 Elder Marco 2009-07-09 14:58:05 EDT
Created attachment 351121 [details]
Attached traceback automatically from anaconda.
Comment 15 bugchaser 2009-07-16 22:35:11 EDT
Created attachment 354078 [details]
Attached traceback automatically from anaconda.
Comment 16 redlabour 2009-07-25 07:32:02 EDT
Created attachment 355139 [details]
Attached traceback automatically from anaconda.
Comment 17 redlabour 2009-07-25 07:33:27 EDT
(In reply to comment #16)
> Created an attachment (id=355139) [details]
> Attached traceback automatically from anaconda.  

This Bug is existing since Fedora 9 - will the Installer ever be fixed? *argh*
Comment 18 Andoni Martín 2009-07-27 20:50:28 EDT
Created attachment 355342 [details]
Attached traceback automatically from anaconda.
Comment 19 bugchaser 2009-07-28 23:45:44 EDT
Created attachment 355488 [details]
Attached traceback automatically from anaconda.
Comment 20 Juan Carlos 2009-07-30 16:10:53 EDT
Created attachment 355725 [details]
Attached traceback automatically from anaconda.
Comment 21 Eric Sandeen 2009-08-11 14:37:19 EDT
Created attachment 357063 [details]
Attached traceback automatically from anaconda.
Comment 22 Eduardo 2009-09-10 12:04:09 EDT
Created attachment 360529 [details]
Attached traceback automatically from anaconda.
Comment 23 Bob 2009-09-12 11:42:40 EDT
Created attachment 360788 [details]
Attached traceback automatically from anaconda.
Comment 24 Bob 2009-09-12 13:29:19 EDT
Created attachment 360800 [details]
Attached traceback automatically from anaconda.
Comment 25 Bob Dietrich 2009-09-15 21:54:29 EDT
Created attachment 361171 [details]
Attached traceback automatically from anaconda.
Comment 26 Rahul Anand 2009-09-16 11:38:56 EDT
Created attachment 361302 [details]
Attached traceback automatically from anaconda.
Comment 27 Sebastian Day 2009-09-16 14:51:38 EDT
Created attachment 361353 [details]
Attached traceback automatically from anaconda.
Comment 28 sauvage 2009-09-21 07:10:22 EDT
Created attachment 361909 [details]
Attached traceback automatically from anaconda.
Comment 29 sauvage 2009-10-05 13:27:12 EDT
Created attachment 363720 [details]
Attached traceback automatically from anaconda.
Comment 30 Boyd 2009-10-16 18:33:55 EDT
Created attachment 365098 [details]
Attached traceback automatically from anaconda.
Comment 31 Boyd 2009-10-16 18:41:49 EDT
Created attachment 365099 [details]
Attached traceback automatically from anaconda.
Comment 32 sauvage 2009-10-24 11:45:35 EDT
Created attachment 365955 [details]
Attached traceback automatically from anaconda.
Comment 33 Darr247 2009-10-24 18:40:54 EDT
Created attachment 365990 [details]
Attached traceback automatically from anaconda.
Comment 34 Darr247 2009-10-24 18:53:35 EDT
Created attachment 365991 [details]
Attached traceback automatically from anaconda.
Comment 35 Darr247 2009-10-24 19:43:39 EDT
Created attachment 365994 [details]
Attached traceback automatically from anaconda.
Comment 36 Alexander 2009-10-28 00:29:41 EDT
Created attachment 366384 [details]
Attached traceback automatically from anaconda.
Comment 37 Alexander 2009-10-28 00:40:45 EDT
Created attachment 366385 [details]
Attached traceback automatically from anaconda.
Comment 38 zafasach 2009-11-01 11:45:34 EST
Created attachment 367016 [details]
Attached traceback automatically from anaconda.
Comment 39 kruvalig 2009-11-13 10:57:56 EST
Created attachment 369448 [details]
Attached traceback automatically from anaconda.
Comment 40 AG 2009-11-14 14:10:21 EST
Created attachment 369543 [details]
Attached traceback automatically from anaconda.
Comment 41 eduardo 2009-11-16 10:34:36 EST
Created attachment 369717 [details]
Attached traceback automatically from anaconda.
Comment 42 eduardo 2009-11-16 11:55:30 EST
Created attachment 369741 [details]
Attached traceback automatically from anaconda.
Comment 43 Val 2010-02-08 19:07:27 EST
Created attachment 389648 [details]
Attached traceback automatically from anaconda.
Comment 44 vivek 2010-04-20 00:02:12 EDT
Created attachment 407717 [details]
Attached traceback automatically from anaconda.
Comment 45 Millind Nagmoti 2010-05-02 10:15:35 EDT
Created attachment 410803 [details]
Attached traceback automatically from anaconda.

Note You need to log in before you can comment on or make changes to this bug.