Bug 496419 - existing RAID1 md devices show up with zero size
existing RAID1 md devices show up with zero size
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-18 18:45 EDT by Charles R. Anderson
Modified: 2009-04-29 01:08 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-29 01:08:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
storage.log (532.27 KB, text/plain)
2009-04-18 18:45 EDT, Charles R. Anderson
no flags Details
program.log (8.96 KB, text/plain)
2009-04-18 18:46 EDT, Charles R. Anderson
no flags Details
anaconda.log (156.76 KB, text/plain)
2009-04-18 18:47 EDT, Charles R. Anderson
no flags Details
udevadm info --exportdb (122.68 KB, text/plain)
2009-04-18 18:48 EDT, Charles R. Anderson
no flags Details
mdadm --examine /dev/sda2; mdadm --examine /dev/sdb2 (1.48 KB, text/plain)
2009-04-18 18:49 EDT, Charles R. Anderson
no flags Details
output of /proc/mdstat (830 bytes, text/plain)
2009-04-18 18:50 EDT, Charles R. Anderson
no flags Details

  None (edit)
Description Charles R. Anderson 2009-04-18 18:45:34 EDT
Created attachment 340183 [details]
storage.log

Description of problem:

Existing system with RAID1 partitions show up under custom partitioning with 0 size.  Trying to use format the md device as Physical Volume (Encrypted) and then making a VG causes LUKS device to show up with a size of -8.00 MB.

Version-Release number of selected component (if applicable):
11.5.0.45

How reproducible:
always

Steps to Reproduce:
1. have existing RAID1 /dev/md0, /dev/md1, etc. made with two identical disks
2. boot anaconda and choose custom partitioning
3. look at RAID Devices in list
4. try to format one as Physical Volume (LVM) and check 'Encrypt'
5. click LVM to create a LVM Volume Group.
  
Actual results:
On my disk I have /dev/md0 through /dev/md12, and they all show up as Size (MB) 0.  On step 5 above, I see "[x] luks-md1       -8.00 MB" in the LVM screen.

Expected results:
Show correct sizes of md devices.  Allow formatting/installing to existing md devices.

Additional info:
Some of the other existing md devices have other existing LVM VGs with encryption which were not detected at all.  F11 Beta did detect those and request the passphrases for them, but 11.5.0.45 no longer does this, probably due to this 0-size bug.
Comment 1 Charles R. Anderson 2009-04-18 18:46:36 EDT
Created attachment 340184 [details]
program.log
Comment 2 Charles R. Anderson 2009-04-18 18:47:03 EDT
Created attachment 340185 [details]
anaconda.log
Comment 3 Charles R. Anderson 2009-04-18 18:48:07 EDT
Created attachment 340186 [details]
udevadm info --exportdb
Comment 4 Charles R. Anderson 2009-04-18 18:49:47 EDT
Created attachment 340187 [details]
mdadm --examine /dev/sda2; mdadm --examine /dev/sdb2
Comment 5 Charles R. Anderson 2009-04-18 18:50:49 EDT
Created attachment 340188 [details]
output of /proc/mdstat
Comment 6 David Lehman 2009-04-28 20:11:24 EDT
Please retest with anaconda-11.5.0.47-1 or later. Several fixes related directly to pre-existing md devices were first included in that version.
Comment 7 Charles R. Anderson 2009-04-29 01:08:58 EDT
Verified fixed.

Note You need to log in before you can comment on or make changes to this bug.