Bug 496493 - Failed to initialize PolicyKit context
Summary: Failed to initialize PolicyKit context
Alias: None
Product: Fedora
Classification: Fedora
Component: PolicyKit-gnome
Version: 11
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: David Zeuthen
QA Contact: Fedora Extras Quality Assurance
Depends On:
TreeView+ depends on / blocked
Reported: 2009-04-19 16:20 UTC by darrell pfeifer
Modified: 2010-06-28 12:05 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2010-06-28 12:05:44 UTC
Type: ---

Attachments (Terms of Use)
virtual machine manager first bug error (200.16 KB, text/plain)
2009-04-19 16:20 UTC, darrell pfeifer
no flags Details

Description darrell pfeifer 2009-04-19 16:20:58 UTC
Created attachment 340242 [details]
virtual machine manager first bug error

Description of problem:

When starting gnome control panel apps that require root access, the apps fail to start and produce a bug report.

Version-Release number of selected component (if applicable):


How reproducible:

Start a control panel that requires root access. I have tried both virtual machine manager and power management.

Steps to Reproduce:
Actual results:

Bug report dialog

Expected results:

Additional info:

Selinux is turned off.

For gnome power manager, .xsession-errors says

** (gnome-power-preferences:14526): WARNING **: Failed to initialize PolicyKit context: (null)
[WARN 14526] polkit-error.c:156:polkit_error_free(): error != NULL

For virtual machine manager, the bug report text file says

---- Critical and fatal warnings logged during execution ----

** PolicyKitGnome **: error creating PK context: (null)

Comment 1 Matthias Clasen 2009-04-20 18:43:43 UTC
> Start a control panel that requires root access. I have tried both virtual
> machine manager and power management.

This is a little unclear. gnome-power-manager is not supposed to be run as root. It uses PolicyKit precisely so that it can avoid that...

Comment 2 darrell pfeifer 2009-04-20 19:04:43 UTC
Let me rephrase to be more clear.

As a regular user, if I go to the menu and select System/Preferences/PowerManagement, I am not presented with a dialog box asking for the root password. Instead, I get the gnome dump message.

The same situation happens when, as a regular user, I go to System Tools/Virtual Machine Manager

Comment 3 darrell pfeifer 2009-05-07 14:00:18 UTC
The problem has gone away.

There was no update to PolicyKit-gnome, bu


was just updated.

Comment 4 darrell pfeifer 2009-05-21 21:08:44 UTC
This problem has returned again  with


Reverting back to comment 3 fixes the problem.

Comment 5 Daniel Walsh 2009-05-27 11:25:27 UTC
policycoreutils has nothing to do with PolicyKit.  policycoreutils is the coreutils of SELinux.  This is not an SELinux issue.

Comment 6 Bug Zapper 2009-06-09 14:07:56 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:

Comment 7 Bug Zapper 2010-04-27 13:46:54 UTC
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 

Comment 8 Bug Zapper 2010-06-28 12:05:44 UTC
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.