Bug 496518 - gnomint: $RPM_OPT_FLAGS not used
gnomint: $RPM_OPT_FLAGS not used
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnomint (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Huffman
Fedora Extras Quality Assurance
: Patch, Reopened
Depends On:
Blocks: DebugInfo
  Show dependency treegraph
 
Reported: 2009-04-19 17:16 EDT by Ville Skyttä
Modified: 2009-04-29 12:06 EDT (History)
1 user (show)

See Also:
Fixed In Version: 0.9.1-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-29 12:06:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Use $RPM_OPT_FLAGS; specfile part (805 bytes, patch)
2009-04-19 17:16 EDT, Ville Skyttä
no flags Details | Diff
Use $RPM_OPT_FLAGS; sources part (364 bytes, patch)
2009-04-19 17:16 EDT, Ville Skyttä
no flags Details | Diff

  None (edit)
Description Ville Skyttä 2009-04-19 17:16:15 EDT
Created attachment 340258 [details]
Use $RPM_OPT_FLAGS; specfile part

http://fedoraproject.org/wiki/Packaging/Debuginfo
https://www.redhat.com/archives/fedora-devel-list/2009-April/msg01233.html

Fix attached - using a patch instead of inline sed makes problems like this easier to spot.  Also, --disable-dependency-tracking results in cleaner build logs and possibly slight build speedup.
Comment 1 Ville Skyttä 2009-04-19 17:16:54 EDT
Created attachment 340259 [details]
Use $RPM_OPT_FLAGS; sources part
Comment 2 Adam Huffman 2009-04-21 19:14:03 EDT
Done.  Apologies for not having spotted your original mail.
Comment 3 Ville Skyttä 2009-04-26 15:03:53 EDT
Not fixed:
http://kojipkgs.fedoraproject.org/packages/gnomint/0.9.1/3.fc11/data/logs/x86_64/

The build log for this build doesn't show any patches tried to be applied, and it is still not using $RPM_OPT_FLAGS.

Also, the devel branch in CVS shows only the change log entry for fix for this bug added, but the actual fix is not there, it's only in the F-11 branch.  There are now two branches with the same NEVR (gnomint-0.9.1-3%{?dist}) but differences in specfiles, please fix this.
Comment 4 Adam Huffman 2009-04-26 15:30:26 EDT
Yes, I did it for F-10 but it appears I didn't complete it for F-11, which I will correct.

One question about NEVR - I was a little unsure how to handle the fact that the F-11 branch had already been incremented automatically for the mass rebuild, whereas the others hadn't.
Comment 5 Ville Skyttä 2009-04-26 16:56:21 EDT
If the same specfile works for all branches, you can just it for all of them, it doesn't matter if it results in going from e.g. -2%{?dist} to -4%{?dist} in let's say F-10.
Comment 6 Adam Huffman 2009-04-26 17:47:55 EDT
Okay, thanks for the clarification.

Have tried fixing it in -devel and it builds locally when checked out in a fresh directory, but it fails on koji because it can't find the patch.

I've tried re-adding the patch but it says:

[adam@vaio devel]$ cvs add gnomint-0.9.1-cflags.patch 
cvs add: gnomint-0.9.1-cflags.patch added independently by second party

Apologies for all this extra work - it's my first package and I'm still learning...
Comment 7 Ville Skyttä 2009-04-27 11:12:39 EDT
No problem.  In case of problems, your sponsor should be able to help, and if not, someone in the Fedora infrastructure team but let's see if I can do it for this case.

I don't know what happened but I *guess* something that could lead to this error is that you 'cvs add'ed the patch to devel/ in some working copy but forgot to commit it and now CVS barfs when you try to add it again in another.  I suppose the patch needs to be 'cvs rm'd in devel/ before it can be added there again.
Comment 8 Adam Huffman 2009-04-27 17:42:36 EDT
Thanks for your perseverance.

I have cvs removed the patch from the working copy and re-added it.  However, the devel build fails with the same error, complaining that it can't see the patch.

The patch is listed in CVS in the devel branch, with version 1.3, but it doesn't appear in the checkout.log for the task in koji e.g.

http://koji.fedoraproject.org/koji/getfile?taskID=1324823&name=build.log
Comment 9 Ville Skyttä 2009-04-27 18:01:02 EDT
That's because koji checks out using the tag gnomint-0_9_1-4_fc12:
http://koji.fedoraproject.org/koji/getfile?taskID=1324823&name=checkout.log

...but no version of the patch has that tag:
http://cvs.fedoraproject.org/viewvc/devel/gnomint/gnomint-0.9.1-cflags.patch?view=log

Something like this in your gnomint/devel/ working tree, then resubmitting the existing failed koji job from the web interface should work (there should be no need to touch any other files, bump revision in the specfile or the like in CVS, just do the tag):

$ cvs tag gnomint-0_9_1-4_fc12 gnomint-0.9.1-cflags.patch
Comment 10 Adam Huffman 2009-04-28 16:13:55 EDT
Just tried that and cvs isn't happy:

ERROR: Tag gnomint-0_9_1-4_fc12 has been already created.
The following tags have been created so far
gnomint-0_5_4-2_fc11:devel:verdurin:1223837441
gnomint-0_5_4-2_fc9:F-9:verdurin:1223843324
gnomint-0_5_4-2_fc10:F-10:verdurin:1223843446
gnomint-0_6_0-1_fc9:F-9:verdurin:1228503851
gnomint-0_6_0-1_fc10:F-10:verdurin:1228504458
gnomint-0_9_1-1_fc11:devel:verdurin:1232573270
gnomint-0_9_1-1_fc10:F-10:verdurin:1232574169
gnomint-0_9_1-1_fc9:F-9:verdurin:1232575630
gnomint-0_9_1-2_fc11:devel:jkeating:1235519366
gnomint-0_9_1-2_fc10:F-10:verdurin:1240353500
gnomint-0_9_1-3_fc11:F-11:verdurin:1240354102
gnomint-0_9_1-3_fc12:devel:verdurin:1240355550
gnomint-0_9_1-4_fc11:F-11:verdurin:1240779462
gnomint-0_9_1-4_fc12:devel:verdurin:1240781174
cvs tag: Pre-tag check failed
cvs [tag aborted]: correct the above errors first!
Comment 11 Adam Huffman 2009-04-28 19:08:06 EDT
Sought advice on #fedora-devel and dgilmore suggested bumping the release, only in the devel/ branch, so that's what I did.  It builds normally now in devel:

http://koji.fedoraproject.org/koji/taskinfo?taskID=1327158
Comment 12 Ville Skyttä 2009-04-29 12:06:05 EDT
Yep, build log and debuginfo contents look better now.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.