Bug 496535 - anaconda doesn't recognise lvm on whole device
anaconda doesn't recognise lvm on whole device
Status: CLOSED DUPLICATE of bug 489991
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-19 20:37 EDT by Martin Ebourne
Modified: 2009-04-20 10:45 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-20 10:45:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Ebourne 2009-04-19 20:37:24 EDT
Description of problem:
When upgrading a working system that has lvm on a whole disk (ie. no partition table), anaconda doesn't recognise it and offers instead to reinitialise the disk losing all data.

Version-Release number of selected component (if applicable):
rawhide boot.img downloaded on 2009/04/19

How reproducible:
Every time

Steps to Reproduce:
1. Have running system with lvm on whole disk (ie. pvcreate /dev/sdc; etc)
2. Use ISO to upgrade
3. Answer prompts in standard way
  
Actual results:
When searching for disks anaconda pops up a box for each one that has lvm on whole disk and offers to delete all of your data.

Expected results:
Should grok lvm on whole disk and not offer to delete all of my data

Additional info:
While no harm is done if you say no to the polite offer, this really is a massive risk, it's far too easy to accidentally click the wrong button.

I'm pretty sure this was the cause of my brother losing an entire disk's worth of data when re-installing F10, he had a second disk which was lvm on whole disk I'd set up for him, which magically lost all its data, he had no idea why.
Comment 1 Chris Lumens 2009-04-20 10:45:45 EDT
We don't really support disks without partitions, though that needs to change.  Duping to another bug that has the same problems.

*** This bug has been marked as a duplicate of bug 489991 ***

Note You need to log in before you can comment on or make changes to this bug.