Bug 496539 - KMS:RV350 AP:Radeon 9600 monitor resolution capped at 1280x1024
KMS:RV350 AP:Radeon 9600 monitor resolution capped at 1280x1024
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-19 21:13 EDT by Callum Lerwick
Modified: 2010-06-28 08:06 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 08:06:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log (142.72 KB, text/plain)
2009-04-19 21:13 EDT, Callum Lerwick
no flags Details
F11 Xorg log (178.30 KB, text/plain)
2009-05-21 02:34 EDT, Callum Lerwick
no flags Details
Xorg log with xorg-x11-drv-ati-6.12.2-14 (56.01 KB, text/plain)
2009-05-23 04:48 EDT, Panu Matilainen
no flags Details
Xorg log xorg-x11-drv-ati-6.12.2-14 with nomodeset (80.32 KB, text/plain)
2009-05-23 05:35 EDT, Panu Matilainen
no flags Details

  None (edit)
Description Callum Lerwick 2009-04-19 21:13:35 EDT
Created attachment 340269 [details]
Xorg log

Description of problem:
For some reason in Fedora 11 my monitor resolution has been capped at 1280x1024. I have a 19in CRT which is capable of 1600x1200 though I was running it at 1400x1050 in F10. It doesn't seem to matter if I use modesetting or not.

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.12.2-2.fc11.x86_64
kernel-2.6.29.1-85.fc11.x86_64
xorg-x11-server-Xorg-1.6.1-1.fc11.x86_64
Comment 1 Callum Lerwick 2009-05-21 00:17:50 EDT
Still busticated as of:

xorg-x11-server-Xorg-1.6.1-11.fc11.x86_64
xorg-x11-drv-ati-6.12.2-14.fc11.x86_64
kernel-2.6.29.3-140.fc11.x86_64

And it seems with modesetting enabled, I can't even get 1280x960@85. I have to choose between 1280x1024 and 1024x768. And only 75hz refresh seems to be selectable. Attaching current Xorg log.

Also may want to cross reference with bz#487432, it's the same system.
Comment 2 Callum Lerwick 2009-05-21 02:34:30 EDT
Created attachment 344916 [details]
F11 Xorg log
Comment 3 Panu Matilainen 2009-05-23 04:38:34 EDT
Same here, this is sorta the opposite of what I had in F10 where it would pick a sky-high resolution (bug 470217) but could be capped with xorg.conf. Now, with or without xorg.conf I can't get higher than 1280x1024 whereas the monitor can do up to 1600x1200 (but I start needing eyeglasses with that so 1400x1050 is what I usually use :)

Notice something funny here? Resolution 0x0 offered...
[pmatilai@turre ~]$ cat xrandr-xorg-x11-drv-ati-6.12.2-14.fc11.x86_64.txt 
Screen 0: minimum 320 x 200, current 1024 x 768, maximum 4096 x 4096
VGA-0 connected 1024x768+0+0 (normal left inverted right x axis y axis) 350mm x 260mm
   1280x1024      75.0  
   1024x768       75.1*    60.0  
   800x600        60.3  
   640x480        75.0     60.0  
   720x400        70.1  
   0x0             0.0  
DVI-0 disconnected (normal left inverted right x axis y axis)

With all except radeon-6.12.2-stable-branch.patch patches commented out, 1600x1200 is back:
[pmatilai@turre ~]$ cat xrandr-nomodeset-patches.txt 
Screen 0: minimum 320 x 200, current 1600 x 1200, maximum 3520 x 1600
VGA-0 connected 1600x1200+0+0 (normal left inverted right x axis y axis) 350mm x 260mm
   1600x1200      75.0*+
   1280x1024      85.0     75.0     60.0  
   1024x768       85.0     75.0     60.0  
   800x600        85.1     60.3  
   640x480        85.0     75.0     59.9  
   720x400        70.1  
DVI-0 disconnected (normal left inverted right x axis y axis)
S-video disconnected (normal left inverted right x axis y axis)
Comment 4 Panu Matilainen 2009-05-23 04:48:47 EDT
Created attachment 345186 [details]
Xorg log with xorg-x11-drv-ati-6.12.2-14

Attached is X startup log with xorg-x11-drv-ati-6.12.2-14, also tried building xorg-x11-drv-ati-6.12.2-15 from CVS, no change in behavior. More logs from this system (how it should look like) in bug 470217.
Comment 5 Panu Matilainen 2009-05-23 05:35:49 EDT
Created attachment 345187 [details]
Xorg log xorg-x11-drv-ati-6.12.2-14 with nomodeset

Adding nomodeset also brings back 1600x1200 here, but no 1400x1050, log attached in case its of any use/interest. OTOH nomodeset results in piles of "freeing invalid memtype" messages on shutdown:
Xorg:5434 freeing invalid memtype c8102000-c8112000
Xorg:5434 freeing invalid memtype c8112000-c8122000
Xorg:5434 freeing invalid memtype c8132000-c8142000
...

Speaking of modeset, plymouth doesn't run in graphical mode in F11 on this hw, whereas on F10 it did but that's probably another story...
Comment 6 Jérôme Glisse 2009-10-14 07:25:52 EDT
Can you test with fedora 12 livecd and report if it works with it.
Comment 7 Panu Matilainen 2009-10-15 01:45:30 EDT
Tested on 6.10.2009 rawhide, 1600x1200 was correctly detected as the largest supported mode out of the box but 1400x1050 was still missing. Can't further test this case as I've since then bought a new monitor with which this is not an issue.
Comment 8 Jérôme Glisse 2009-10-15 10:11:18 EDT
Ok clausing this bug, i think for 1400x1050 you would have need a custom modeset line.
Comment 9 Callum Lerwick 2009-11-11 12:59:43 EST
Nice bug hijack. 1400x1050 worked just fine in F10 and earlier, so not supporting it is a regression. It is/was a common LCD panel resolution before widescreen became the in-thing. Also 1600x1200 used to work, but now doesn't.

Once F12 becomes available I'll try it again.
Comment 10 Jérôme Glisse 2009-11-12 08:29:21 EST
If it doesn't work on f12 please reupdate the version then. We are focussing on f12 issue for the time being.
Comment 11 Bug Zapper 2010-04-27 09:47:31 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 12 Vedran Miletić 2010-05-24 13:45:28 EDT
Improving summary.

---

Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

[This triage is part of collective effort done by students of University of
Rijeka Department of Informatics.]
Comment 13 Bug Zapper 2010-06-28 08:06:16 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.