This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 496542 - (Input, w/o, Xfce) IBus in not working on XFCE
IBus in not working on XFCE
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: imsettings (Show other bugs)
rawhide
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Akira TAGOH
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-19 21:48 EDT by das
Modified: 2009-04-20 08:49 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-20 08:49:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description das 2009-04-19 21:48:16 EDT
Description of problem:
I can use the IBus input method to enter Bengali text if I log-in to Gnome, but it is not working on XFCE.

Version-Release number of selected component (if applicable):
IBus 1.1.0.20090413
Xfce 4 version 4.6.0 (Xfce 4.6)

How reproducible:
Always

Steps to Reproduce:
--
  
Actual results:
IBus does not work, even after any number of restart of X or Xfce or IBus. And for that matter, scim on Xfce is not working too. 

Expected results:
IBus or Scim input methods should work on Xfce. 


Additional info:
Comment 1 Peng Huang 2009-04-20 00:56:05 EDT
Can you see ibus icon in systray area? if yes, please try use gedit in terminal with below command. 
GTK_IM_MODULE=ibus gedit.

If it works, please let me know. thanks.
Comment 2 das 2009-04-20 01:11:41 EDT
1. Yes, the icon is there on systray.

2. Yes, when I started gedit with your command, I could give Bengali input. 

This is great. Will the same command work with OOo.
Comment 3 das 2009-04-20 01:15:36 EDT
Oh, you are great. I started oowriter like that and I could give Bangla (that is, Bengali) input.
Comment 4 Peng Huang 2009-04-20 01:17:33 EDT
I think it is because gtk does not choice right im module. It should be a
problem of imsetting.

(In reply to comment #2)
> 1. Yes, the icon is there on systray.
> 
> 2. Yes, when I started gedit with your command, I could give Bengali input. 
> 
> This is great. Will the same command work with OOo.  
Yeah. You could set env GTK_IM_MODULE=ibus to control im module by self.
Comment 5 das 2009-04-20 01:33:23 EDT
Where to set the GTK_IM_MODULE? In .bashrc?
Comment 6 Peng Huang 2009-04-20 01:45:44 EDT
You could set it in .bashrc. But you need re login your desktop session.
BTW, Maybe Tagoh-san could give you a better suggestion.
Comment 7 das 2009-04-20 02:03:07 EDT
Where to set the GTK_IM_MODULE? In .bashrc?
Comment 8 das 2009-04-20 02:06:18 EDT
This was quite queer, it reported about a funny 'mid-air collision' and repeated my comment. 

Anyway, the question is, will 'source ~/.bashrc' work after I add that line in .bashrc even if I don't login?
Comment 9 das 2009-04-20 02:34:17 EDT
Thank you. Adding the line 'export GTK_IM_MODULE=ibus' in .bashrc and 'source .bashrc' did it.
Comment 10 das 2009-04-20 02:44:22 EDT
But, there is a problem, I have to run everything from the command prompt. Is there any way out? How to make this variable system-wide available?
Comment 11 Akira TAGOH 2009-04-20 04:11:46 EDT
Please make sure if you have imsettings-xfce installed.
Comment 12 Rahul Sundaram 2009-04-20 04:24:37 EDT
Kevin,

Can you make sure imsettings-xfce is installed by default in the Xfce live cd?
Comment 13 das 2009-04-20 05:08:11 EDT
No, imsettings-xfce was not installed. And now I have installed it, after you said. 

I installed F11 from the Beta-DVD and then installed the group Xfce after I updated my yum. Package imsettings-xfce was not installed by yum.

What to do now?
Comment 14 das 2009-04-20 05:15:29 EDT
Grand. Now I am getting it in oowriter too, without starting it from the command prompt. 

Will it remain like that? And in that case can I delete the .bashrc added line?
Comment 15 Rahul Sundaram 2009-04-20 05:18:24 EDT
Das,

    IBus should work and you shouldn't need to run commands from the command line
    anymore. You can remove the workarounds and it would work fine. Can you confirm that?

    Also, while installing from the DVD, did you also choose to install Bengali
    support during installation?

    If not, did you do a yum install @bengali-support ?
Comment 16 das 2009-04-20 07:53:08 EDT
(In reply to comment #15)

> 
>     IBus should work and you shouldn't need to run commands from the command
> line
>     anymore. You can remove the workarounds and it would work fine. Can you
> confirm that?

Yes, I did what you suggested. Without taking any chance I hashed out the .bashrc insert and did a reboot. And oowriter is taking the 'Ctrl+Space' trigger and starting Bangla keyboard.

> 
>     Also, while installing from the DVD, did you also choose to install Bengali
>     support during installation?
> 
>     If not, did you do a yum install @bengali-support ?  

No, I did not install Bangla support from the DVD. 

Neither I did 'yum install @bengali-support': I did not know the command before reading this comment of yours. 

First I did a 'yum -y update' and did a reboot. 

Now I searched for everything Bengali and installed things like 'aspell' and 'hunspell', and kept out things like openoffice.org bn langpacks, moodle-bn and kde-bn because I don't need them. 

And already after the primary install from the DVD the default was Gnome and I saw there the iBus thing and liked it, this time when I did install many other things and the groups like Xfce and Virtualization and the 'bengali' things, I did not install the scim things that I usually do after searching for the string 'bengali'. 

After this large scale yum install I did log into Xfce and saw that iBus was not working. Then from yum I installed the bengali-scim thing which as dependency brought all scim components but that too did not work.

Thank you for all the helps.
Comment 17 Akira TAGOH 2009-04-20 08:49:29 EDT
imsettings-xfce won't be installed by default unless you choose any language support that contains scim.

Anyway, closing..

Note You need to log in before you can comment on or make changes to this bug.