Bug 496543 - Software install - Internal System Error
Software install - Internal System Error
Status: CLOSED DUPLICATE of bug 495087
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
9
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-19 21:53 EDT by alex
Modified: 2014-01-21 18:09 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-21 10:36:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of the error (531.03 KB, image/png)
2009-04-19 21:55 EDT, alex
no flags Details

  None (edit)
Description alex 2009-04-19 21:53:47 EDT
Description of problem:

Every time I try to install something using either yum in the command line or the software installer, I get an error.  In the gui software installer i get an 'internal system error' and on the command line i get repeated trying other mirrors and then a traceback error.

Version-Release number of selected component (if applicable):


How reproducible:
every time on my computer

Steps to Reproduce:
1.open software installer
2.type in something to install (example: openoffice)
3.says 'downloading list of packages' then error occurs 
  
Actual results:


Expected results:


Additional info:

pretty new with Fedora and linux in general...so more info is appreciated
Comment 1 alex 2009-04-19 21:55:18 EDT
Created attachment 340270 [details]
screenshot of the error
Comment 2 James Antill 2009-04-20 09:53:40 EDT
What we need is all the text you get when you run yum from the command line, can you paste that into a comment?
Comment 3 locelihyxusyqexe 2009-05-21 00:56:35 EDT
I'm pretty sure I have the same problem. This is what I got: 


An internal system error has occurred:

More Details:
----------------------------------------------------------------- 
Error Type: <type 'exceptions.TypeError'>
Error Value: rpmdb open failed
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 2316, in <module>
    main()
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 2312, in main
    backend = PackageKitYumBackend('', lock=True)
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 182, in __init__
    self.yumbase = PackageKitYumBase(self)
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 2255, in __init__
    self.repos.confirm_func = self._repo_gpg_confirm
  File : /usr/lib/python2.5/site-packages/yum/__init__.py, line 589, in <lambda>
    repos = property(fget=lambda self: self._getRepos(),
  File : /usr/lib/python2.5/site-packages/yum/__init__.py, line 395, in _getRepos
    self._getConfig() # touch the config class first
  File : /usr/lib/python2.5/site-packages/yum/__init__.py, line 192, in _getConfig
    self._conf = config.readMainConfig(startupconf)
  File : /usr/lib/python2.5/site-packages/yum/config.py, line 774, in readMainConfig
    yumvars['releasever'] = _getsysver(startupconf.installroot, startupconf.distroverpkg)
  File : /usr/lib/python2.5/site-packages/yum/config.py, line 844, in _getsysver
    idx = ts.dbMatch('provides', distroverpkg)
-----------------------------------------------------------------
Comment 4 seth vidal 2009-05-21 10:36:05 EDT
495087

*** This bug has been marked as a duplicate of bug 495087 ***

Note You need to log in before you can comment on or make changes to this bug.