Bug 496549 - (galeon-gmail) New filter cannot be created in Gmail using Galeon
New filter cannot be created in Gmail using Galeon
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xulrunner (Show other bugs)
rawhide
i686 Linux
low Severity high
: ---
: ---
Assigned To: Denis Leroy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-19 22:34 EDT by das
Modified: 2009-05-02 17:26 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-02 09:39:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of non-reproduction (139.17 KB, image/png)
2009-04-23 03:24 EDT, Matěj Cepl
no flags Details
Epiphany-freeze-screen (183.42 KB, image/png)
2009-04-23 11:11 EDT, das
no flags Details
Firefox-freeze-screen (189.88 KB, image/png)
2009-04-23 11:13 EDT, das
no flags Details
Galeon-freeze-screen (172.34 KB, image/png)
2009-04-23 11:14 EDT, das
no flags Details

  None (edit)
Description das 2009-04-19 22:34:57 EDT
Description of problem:
'Create a New Filter' is bringing up the usual window, but whenever some new criterion is entered and 'Test Search' is clicked, everything other than 'Cancel' is greyed out. And that too does not work. Coming back to 'Inbox' shows no mails on the right pane. Reloading the page shows it again.

Version-Release number of selected component (if applicable):
uname -r: 2.6.29.1-85.fc11.i686.PAE
galeon --version: GNOME galeon 2.0.7

How reproducible:
Every time

Steps to Reproduce:
1.Go to 'Create a New Filter'
2.Enter a new criterion
3.Click 'Test Search'
  
Actual results:
Software stops functioning

Expected results:
A new filter should be created.

Additional info:
Comment 1 das 2009-04-19 23:09:57 EDT
The same thing is happening with Firefox and Midori on F11. So, this is not specific to Galeon. I will try Opera and report that here.
Comment 2 das 2009-04-19 23:24:14 EDT
Yes, Opera could do it. Though it reported that I have to download and install the 'flash' plugin from Adobe, but without that step it worked too. I could create a new filter.
Comment 3 Denis Leroy 2009-04-20 03:08:12 EDT
Assigning to xulrunner.
Comment 4 Matěj Cepl 2009-04-20 11:30:51 EDT
Works for me with firefox-3.1-0.11.beta3.fc11.x86_64 and xulrunner-1.9.1-0.11.beta3.fc11.x86_64 

Is there something special about your configuration, plugins, network, something, which would enable us to reproduce it here?
Comment 5 das 2009-04-20 12:09:16 EDT
Just now I tried it with Epiphany, in another tab, and exactly the same thing happened. What you wanted to know, "anything special" is too general for me to give you feedback. And I am not at all technical, not any developer, just an user. Anyway I am trying. 

My software versions are:
Mozilla XULRunner 1.9.1b3 - 20090327190835
GNOME epiphany 2.26.1
Mozilla Firefox 3.1b3
Midori 0.1.5
GNOME galeon 2.0.7

uname -r: 2.6.29.1-100.fc11.i686.PAE

Processor: Intel(R) Core(TM)2 Duo CPU     E8400  @ 3.00GHz

Motherboard: Intel DG41TY

The graphic driver is still not there in F10, 'xdriver=vesa' enables a kind of install. So, I had to go to F11, that driver is there, though the audio driver is still not there. I am telling you these because maybe there lies 'anything special'. Maybe this driver has got something to with it. Anyway, it is no 'urgent' bug in the sense that Opera is there.
Comment 6 Matěj Cepl 2009-04-21 07:45:51 EDT
Hmm, OK, I'll try more specific questions. Can you reproduce this with firefox in safe mode, i.e., start it as

firefox -safe-mode

Thank you
Comment 7 das 2009-04-21 10:43:33 EDT
Yes, you were right. Just now I created a filter by starting firefox that way. Will that work with Epiphany? Or Midori or Galeon? Usually I don't use firefox. It seems too heavy, more like IE in MSW.
Comment 8 Denis Leroy 2009-04-21 12:07:59 EDT
Works for me in firefox, and does not work for me with both epiphany and galeon. Xulrunner specific issue ?
Comment 9 Matěj Cepl 2009-04-23 03:24:50 EDT
Created attachment 340878 [details]
screenshot of non-reproduction

(In reply to comment #8)
> Works for me in firefox, and does not work for me with both epiphany and
> galeon. Xulrunner specific issue ?  

Actually, I cannot reproduce it even with epiphany-2.26.1-1.fc11.x86_64 ... see attached screenshot. No button is greyed out.
Comment 10 Matěj Cepl 2009-04-23 03:27:51 EDT
Throwing back to galeon land. I am not saying that xulrunner might do something incorrectly, but I think what's needed is more investigation from epiphany/galeon folks.
Comment 11 das 2009-04-23 11:11:58 EDT
Created attachment 340949 [details]
Epiphany-freeze-screen

Trying to create a filter in gmail greying out switches in Epiphany
Comment 12 das 2009-04-23 11:13:26 EDT
Created attachment 340950 [details]
Firefox-freeze-screen

Trying to create a gmail filter greying out switches in Firefox
Comment 13 das 2009-04-23 11:14:53 EDT
Created attachment 340951 [details]
Galeon-freeze-screen

Trying to create a gmail filter greying out switches in Galeon
Comment 14 das 2009-05-01 10:24:08 EDT
Thank you friends. 

As you suggested, it was xulrunner doing the crime. 

After today's update of xulrunner I can now create a filter in Gmail in Epiphany. I have not checked the other browsers, but I presume they will work too.
Comment 15 Denis Leroy 2009-05-02 09:39:56 EDT
WORKSFORME now with galeon too. Closing.

Note You need to log in before you can comment on or make changes to this bug.