Bug 496584 - [RFE] RhtsRequires is Not Installing all Requires
[RFE] RhtsRequires is Not Installing all Requires
Status: CLOSED WONTFIX
Product: Beaker
Classification: Community
Component: beah (Show other bugs)
0.5
All Linux
low Severity medium (vote)
: ---
: ---
Assigned To: beaker-dev-list
SimpleHarness
: FutureFeature
: 1169321 (view as bug list)
Depends On: 577796
Blocks: 545868
  Show dependency treegraph
 
Reported: 2009-04-20 04:02 EDT by CAI Qian
Modified: 2017-01-26 09:59 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-01-26 09:59:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description CAI Qian 2009-04-20 04:02:49 EDT
Description of problem:
I have a test called /kernel/errata/4.7.z using,

RhtsRequires:    rh-tests-super-smack

rh-tests-super-smack in turn has the following in its own Makefile,

Requires:        perl-DBI perl-DBD-MySQL mysql mysql-devel mysql-server
postgresql postgresql-devel postgresql-server

However, if I run /kernel/errata/4.7.z test, it won't install the above
"Requires" packages, which cause the test failed.

http://rhts.redhat.com/cgi-bin/rhts/test_log.cgi?id=7728971

Although I can workaround the problem by bumping the Requires field of
all RhtsRequires tests to the calling test, it is hard to maintainable.

Version-Release number of selected component (if applicable):
rhts-release-2-0.noarch
rhtslib-0.6-1.noarch
rhts-legacy-3.5.0-20090330.1.noarch
rhts-devel-python-3.3-31.noarch
rhts-devel-3.3-31.noarch
rhts-scheduler-workflows-3.5.0-20090330.1.noarch
rhts-rh-devel-3.5.0-20090330.1.noarch
rhts-devel-test-env-3.3-31.noarch

How reproducible:
always
Comment 1 Bill Peck 2009-06-19 09:43:01 EDT
Ahh. interesting.  This has showed a serious problem in how were doing this.

RhtsRequires puts requirements in the rpm package but Requires just tells anaconda that we want to install these packages without putting the requirements in the rpm itself.

The reason we don't put the Requires as dependancies in the rpm itself is you can have conflicting requirements between releases.  Its ok to ask anaconda for both packages because we have --ignore-missing in %packages.

We don't want to have to create test rpms for every release.  That would be a nightmare.  What I think we may need to do is create our own packaging format for tests.  Additional info would be in the tests about what requirements they need for each release.

Any other ideas?  For a quick workaround you can put the above Requires from rh-tests-super-smack in /kernel/errata/4.7.z as RhtsRequires.
Comment 2 CAI Qian 2009-06-19 20:07:12 EDT
(In reply to comment #1)
> Ahh. interesting.  This has showed a serious problem in how were doing this.
> 
> RhtsRequires puts requirements in the rpm package but Requires just tells
> anaconda that we want to install these packages without putting the
> requirements in the rpm itself.
> 
> The reason we don't put the Requires as dependancies in the rpm itself is you
> can have conflicting requirements between releases.  Its ok to ask anaconda for
> both packages because we have --ignore-missing in %packages.
> 
> We don't want to have to create test rpms for every release.  That would be a
> nightmare.  What I think we may need to do is create our own packaging format
> for tests.  Additional info would be in the tests about what requirements they
> need for each release.
> 

OK.

> Any other ideas?  For a quick workaround you can put the above Requires from
> rh-tests-super-smack in /kernel/errata/4.7.z as RhtsRequires.  

Yes, that is how we currently workaround this issue, but dumping Requires to the several places is hard to maintain. What I would like is like the following example,

Test A -- Requires: a b c

Test B -- Requires: d e
          rhtsRequires: Test A

When run Test B, it should ideally merge the Requires from rhtsRequires automatically, so we end up with,

Requires: a b c d e

Since if we are putting other tests in rhtsRequires, it makes sense to pull all requires from there first.
Comment 3 Bill Peck 2010-04-07 08:37:54 EDT
Notice:

Legacy RHTS is soon to be retired and replaced by Beaker. As part of
this migration process all RHTS bugs need to be re-verified against a
Beaker instance by the cut-off date

   5pm Monday April 12th UTC-4. 

Please confirm this bug is still relevant to Beaker by re-verifying it
against the stage deployment of Beaker https://beaker-stage.app.eng.bos.redhat.com.

To keep this bug open please comment on it

If it has not received a comment by that date the bug will be closed/wontfix.

After the cutoff date all commented bugs will be moved to the Beaker
product.


thank you
Comment 4 CAI Qian 2010-04-07 09:35:48 EDT
This is still the case for Beaker
Comment 5 Marian Csontos 2010-08-06 05:31:14 EDT
We will need to re-implement dependencies on harness side: see also Bug 577796.
Comment 6 CAI Qian 2011-04-18 05:41:01 EDT
Any update?
Comment 7 Marian Csontos 2011-08-11 05:05:15 EDT
Sorry for late answer. So far no plan to start on this.

This will be likely a part of future major update (rewrite?).
Comment 8 Nick Coghlan 2012-10-17 00:40:10 EDT
Bulk reassignment of issues as Bill has moved to another team.
Comment 9 Nick Coghlan 2012-11-07 01:00:03 EST
Reverting to NEW to more accurately reflect current status.
Comment 11 Dan Callaghan 2014-12-01 22:43:44 EST
*** Bug 1169321 has been marked as a duplicate of this bug. ***
Comment 12 CAI Qian 2017-01-26 09:59:40 EST
I have no interest in this anymore.

Note You need to log in before you can comment on or make changes to this bug.