Bug 496596 - kernel config: reduce HZ to 100 on s390x
kernel config: reduce HZ to 100 on s390x
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
s390x Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-20 05:20 EDT by Jan Glauber
Modified: 2009-04-20 13:52 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-20 13:52:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Glauber 2009-04-20 05:20:47 EDT
CONFIG_HZ=1000 and CONFIG_HZ_1000=y should be changed to
CONFIG_HZ_100=y and CONFIG_HZ=100 in the s390/s390x kernel.

Rationale:
HZ for s390 kernels was always 100 since s390 is a virtualized architecture
that allows huge CPU overcommitment. With a higher HZ value the cost of the
timer interrupts is rising which reduces the performance of Linux guests
that run on shared CPUs. Since the high HZ value is not needed on s390 (no
multimedia stuff :) the HZ value should be changed to 100.
Comment 1 Dave Jones 2009-04-20 13:52:52 EDT
changed in cvs.

Note You need to log in before you can comment on or make changes to this bug.