Bug 496646 - system-config-printer-kde doesn't start
system-config-printer-kde doesn't start
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdeadmin (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: 496808
  Show dependency treegraph
 
Reported: 2009-04-20 10:11 EDT by Mary Ellen Foster
Modified: 2009-04-21 09:00 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-21 09:00:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mary Ellen Foster 2009-04-20 10:11:49 EDT
Description of problem:
With the default install (from the live image), running system-config-printer-kde results in:
Traceback (most recent call last):
  File "/usr/bin/system-config-printer-kde", line 67, in <module>
    import config
ImportError: No module named config

If I install system-config-printer (which is not an explicit dependency, but maybe should be), the error changes: a window briefly pops up, and then disappears with the following console output:
Traceback (most recent call last):
  File "/usr/bin/system-config-printer-kde", line 3249, in <module>
    applet = GUI()
  File "/usr/bin/system-config-printer-kde", line 148, in __init__
    self.newPrinterGUI = np = NewPrinterGUI(self)
  File "/usr/bin/system-config-printer-kde", line 1483, in __init__
    if not config.DOWNLOADABLE_DRIVER_SUPPORT:
AttributeError: 'module' object has no attribute 'DOWNLOADABLE_DRIVER_SUPPORT'

Version-Release number of selected component (if applicable):
system-config-printer-kde-4.2.2-2.fc11.x86_64

How reproducible:
Every time

Additional info: 
I'm running x86_64 if it's relevant ...
Comment 1 Ngo Than 2009-04-20 11:20:43 EDT
it's fixed in 4.2.2-5.
Comment 2 Kevin Kofler 2009-04-20 16:42:42 EDT
You fixed the second bug. But there's also this one:
> Traceback (most recent call last):
>   File "/usr/bin/system-config-printer-kde", line 67, in <module>
>     import config
> ImportError: No module named config
unless system-config-printer is installed. Apparently one or more modules needed by -kde are not in -libs as they should be. We need to fix system-config-printer's package split.
Comment 3 Ngo Than 2009-04-20 17:39:50 EDT
config.py, smburi.py and debug.py should be moved to -libs.
Comment 4 Kevin Kofler 2009-04-21 00:02:10 EDT
Done, I built a system-config-printer-1.1.7-2.fc11 which does this:
http://koji.fedoraproject.org/koji/buildinfo?buildID=98814

I also submitted a build for Than's kdeadmin fix:
http://koji.fedoraproject.org/koji/buildinfo?buildID=98815
(still running at the time of this writing).

Can somebody please try these?
Comment 5 Mary Ellen Foster 2009-04-21 02:13:53 EDT
Seems to work -- I now have
    system-config-printer-kde-4.2.2-3.fc11.x86_64
    system-config-printer-libs-1.1.7-2.fc11.x86_64
(and no system-config-printer) and it starts properly. I can't really test it because I'm at home, not at work, but at least the bugs I reported seem to be gone.
Comment 6 Tim Waugh 2009-04-21 05:23:54 EDT
Unbelievably, KDE is *again* using interfaces that are not exported.

These files are not part of the public API of system-config-printer, which is why they are not in the libs package.  The public API is the 'cups' and 'cupshelpers' Python modules.

I know that we are pressed for time for Fedora 11 but this is not the correct fix.  A future update of system-config-printer will revert this change.

Removing 'modified' status to reflect the fact that the KDE bug remains.
Comment 7 Ngo Than 2009-04-21 09:00:09 EDT
kdeadmin-4_2_2-4_fc11 works now without system-config-printer, it only needs system-config-printer-libs.

Note You need to log in before you can comment on or make changes to this bug.