Bug 496648 - switching vts can kill x
switching vts can kill x
Status: CLOSED DUPLICATE of bug 494411
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
11
i586 Linux
medium Severity high
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-20 10:22 EDT by Christoph Höger
Modified: 2009-07-24 07:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-24 07:57:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg log (41.61 KB, text/plain)
2009-04-20 10:22 EDT, Christoph Höger
no flags Details

  None (edit)
Description Christoph Höger 2009-04-20 10:22:02 EDT
Created attachment 340349 [details]
xorg log

Description of problem:
When switching vts with KMS enabled, sometimes you'll see gdm instead of your old xsession when switching back.

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.6.1-1.fc11.i586
xorg-x11-drv-intel-2.6.99.902-3.fc11.i586

How reproducible:
sometimes

Steps to Reproduce:
1. startup f11 beta with kms enabled
2. login to gnome
3. while gnome is loading switch through your vts and enjoy fast kms-powered switching
  
Actual results:
sometimes x will crash and gdm is restarted

Expected results:
there should be no crash...

Additional info:
I see nothing obvious in the logs
Comment 1 Bug Zapper 2009-06-09 10:12:50 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Matěj Cepl 2009-07-24 07:57:55 EDT

*** This bug has been marked as a duplicate of bug 494411 ***

Note You need to log in before you can comment on or make changes to this bug.