Bug 496685 - With KDM as the login manager, switching to a virtual terminal using CTRL-ALT-Fkey is disabled
With KDM as the login manager, switching to a virtual terminal using CTRL-ALT...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-20 14:05 EDT by Oded Arbel
Modified: 2009-05-27 09:44 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-27 09:44:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oded Arbel 2009-04-20 14:05:38 EDT
Description of problem:
When KDM is the display manager, it is impossible to switch to a text console by holding CTRL, ALT and a function key. It is possible to do it when GDM is the login manager.

On the other hand, with KDM its possible to zap the X server using CTRL-ALT-Backspace while its not possible with GDM - which is supposed to the be default setting IIRC.

Version-Release number of selected component (if applicable):
4.2.2-2

How reproducible:
Always

Steps to Reproduce:
1. Change the display manager to KDM and restart the X server
2. try to switch to a virtual terminal using CTRL-ALT-F2
  
Actual results:
Nothing happens

Expected results:
The text console on vt2 should be presented.

Additional info:
Comment 1 Rex Dieter 2009-04-20 14:27:58 EDT
works for me.  As a matter of fact, I use this feature almost every day.  Odd.

Similarly, CNTL-ALT-F3 ... -F6 don't work for you either?

Double-check your /etc/kde/kdm/kdmrc , does it contain:

ConsoleTTYs=tty2,tty3,tty4,tty5,tty6
?
Comment 2 Lorenzo Villani 2009-04-20 14:34:56 EDT
Works for me too. I can't reproduce this bug on any of my machines.
Comment 3 Oded Arbel 2009-04-20 15:18:50 EDT
Yes, kdmrc contains the specified line.

All function keys do not work for me while KDM is the display manager. I've installed KDM yesterday and have not had any configuration changes:

$ rpm -V $(rpm -qf /etc/kde/kdm/kdmrc)
$
Comment 4 Rex Dieter 2009-04-20 15:22:49 EDT
funky wierd that is.  I'm stumped.
Comment 5 Oded Arbel 2009-04-21 04:05:18 EDT
Could this be related to the fact that KDM allows zapping while it is not allowed in the X server configuration?
Comment 6 Rex Dieter 2009-04-21 08:11:54 EDT
No, doesn't explain why it works for others.
Comment 7 Kevin Kofler 2009-04-21 11:09:51 EDT
Zapping is completely unrelated to VT switching.
Comment 8 Steven M. Parrish 2009-05-26 15:41:36 EDT
Reporter, is this still an issue?  if so since we are unable to reproduce can you please report this upstream.  Don't forget to add the upstream report information to this report so we can monitor it for a fix.
Comment 9 Oded Arbel 2009-05-27 03:37:58 EDT
It works for me now. I don't know what changed.
Comment 10 Steven M. Parrish 2009-05-27 09:44:10 EDT
Thanks for the response.  Will close this as WORKSFORME.  Please feel free to reopen if the problem returns.

Note You need to log in before you can comment on or make changes to this bug.