Bug 496706 - rhythmbox + crossfade plugin causes volume jumps when hitting play
rhythmbox + crossfade plugin causes volume jumps when hitting play
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-20 15:19 EDT by Will Woods
Modified: 2010-01-13 00:45 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-23 09:09:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Will Woods 2009-04-20 15:19:13 EDT
pulseaudio-0.9.15-10.fc11.x86_64
gstreamer-0.10.22-3.fc11.x86_64
rhythmbox-0.12.0-5.fc11.x86_64

Here's the scenario:
0. Enable Rhythmbox crossfading backend, set rb volume to 50%, close rhythmbox
1. Desktop quiet, gnome-volume-control-applet shows volume at 55%
2. Start rhythmbox - rb's volume control reads 50%
3. Press play
4. g-v-c-a jumps to 93%. OW THIS IS REALLY LOUD.
5. Quickly adjust g-v-c-a to 50%.
[Time passes]
6. Pause song.
7. Press play. Volume jumps to 93% again (goto 4).

You can also cause the volume jump by clicking on rhythmbox's volume control button. 

Volume does *not* jump unexpectedly when the crossfading backend is disabled.
Comment 1 Will Woods 2009-04-20 15:44:30 EDT
The second case - volume jumps when using the volume control in rhythmbox - still happens if the crossfade backend is disabled. Alas.

Also, please note that the rb volume control has to be *changed* - moved up or down - to trigger the problem.
Comment 2 Bastien Nocera 2009-04-22 08:42:24 EDT
Should be fixed in 0.12.0.92, could you please test before I try to get this version tagged?
http://koji.fedoraproject.org/koji/buildinfo?buildID=99125
Comment 3 Will Woods 2009-04-22 10:31:42 EDT
Confirmed - this build fixes the volume jumps when hitting play/pause while using the crossfade plugin.

(The volume still jumps around when I use the rb volume control, but I suppose that's a different bug.)
Comment 4 Bastien Nocera 2009-04-23 09:09:47 EDT
Tagging requested.
https://fedorahosted.org/rel-eng/ticket/1610#preview
Comment 5 Jane Dogalt 2010-01-13 00:45:42 EST
I'm not as irate as I used to be.

BUT THIS IS A **!*!&!&! HEALTH HAZARD, and seems to be present in my fedora 11 rhythmbox.

THIS IS UNACCEPTABLE.

I seriously think I may have permanently damanged my hearing because of this.

Not as much as the GNR+metallica concert I went to back in '93.  But that was a willing choice.  Seriously, there need to be measures taken to prevent ANYTHING like this bug from ever happening again, presumably in alsa/pulse.

This bug needs to be reopened and assigned to F11 NOW.

(I have a track record of making loud comments that turn out to be some problem with my environment.  I consider this a serious enough issue that I don't care about getting egg on my face if I'm wrong)

At least put a comment in the bug explaining how to reset gconf, reinstall whatever, blow away whatever file to undo this.

Note You need to log in before you can comment on or make changes to this bug.