Bug 49671 - "rpm --verify mod_ssl" reports files missing immediately after install
Summary: "rpm --verify mod_ssl" reports files missing immediately after install
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: httpd   
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-23 00:36 UTC by Jonathan Kamens
Modified: 2007-04-18 16:35 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-22 08:20:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jonathan Kamens 2001-07-23 00:36:22 UTC
If I run "rpm --verify mod_ssl" immediately after installing it, I see:

missing    /var/cache/ssl_gcache_data.dir
missing    /var/cache/ssl_gcache_data.pag
missing    /var/cache/ssl_gcache_data.sem

These files probably need to be marked "missingok" in the spec file.

I have mod_ssl-2.8.4-7.

I filed this under "apache" because there's no "mod_ssl" component.

Comment 1 Jonathan Kamens 2001-07-29 18:08:31 UTC
And another thing.... The current Rawhide mod_ssl (2.8.4-9) creates
/etc/httpd/conf/ssl.crt/server.crt and /etc/httpd/conf/ssl.key/server.key, but
they aren't listed in the spec file.  Since they are always created, the mod_ssl
package should take ownership of them as config files.


Comment 3 Joe Orton 2004-07-22 08:20:36 UTC
This has been fixed for a while since mod_ssl uses a shared memory
session cache by default now.


Note You need to log in before you can comment on or make changes to this bug.