Bug 496751 - nbd-client should modprobe nbd
nbd-client should modprobe nbd
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: nbd (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Milos Jakubicek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-20 18:27 EDT by Martin Ebourne
Modified: 2009-06-15 22:08 EDT (History)
4 users (show)

See Also:
Fixed In Version: 2.9.12-1.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-15 21:21:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Ebourne 2009-04-20 18:27:24 EDT
Description of problem:
nbd-client gives a misleading error message when nbd module is not loaded, instead it should just modprobe it and work.

Version-Release number of selected component (if applicable):
nbd-2.9.10-2.fc11.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Run nbd-server somewhere, eg. nbd-server 2000 /dev/sdb
2. Run nbd-client locally, eg. nbd-client server-host 2000 /dev/nbd0
  
Actual results:
Assuming module wasn't loaded nbd-client gives this confusing error message:
Error: Can not open NBD: No such file or directory

Expected results:
Should modprobe the nbd module and work, if this is really not possible then should give an error suggesting to modprobe the nbd module.

Additional info:
Comment 1 Milos Jakubicek 2009-05-13 19:20:59 EDT
I've added a tiny patch which prints at least "Please ensure the 'nbd' module is loaded." in this case. Fixed in devel branch (F12), will be part of the next update for F9/10/11.
Comment 2 Fedora Update System 2009-05-13 19:57:59 EDT
nbd-2.9.12-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/nbd-2.9.12-1.fc9
Comment 3 Fedora Update System 2009-05-13 20:02:02 EDT
nbd-2.9.12-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/nbd-2.9.12-1.fc10
Comment 4 Fedora Update System 2009-05-13 20:03:32 EDT
nbd-2.9.12-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/nbd-2.9.12-1.fc11
Comment 5 Fedora Update System 2009-05-15 19:26:27 EDT
nbd-2.9.12-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update nbd'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-4982
Comment 6 Fedora Update System 2009-05-15 19:27:29 EDT
nbd-2.9.12-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update nbd'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-4987
Comment 7 Fedora Update System 2009-05-15 19:33:16 EDT
nbd-2.9.12-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update nbd'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-5030
Comment 8 Warren Togami 2009-05-16 17:53:02 EDT
Is it really necessary to update F9 and F10 for this tiny bug?
Comment 9 Milos Jakubicek 2009-05-16 18:27:02 EDT
I wouldn't update the package just because of this one, the update resolves also bug 454099 and updates from 2.9.10 to 2.9.12 -- do you find this unjustified?

I wanted to do this ASAP so that there is enough time for being in updates-testing before F9 will be EOLed.
Comment 10 Warren Togami 2009-05-16 18:41:53 EDT
It has been broken with bug 454099 for YEARS now.  It is not a serious problem at all.

Anyhow, your choice...
Comment 11 Bug Zapper 2009-06-09 10:15:34 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 12 Fedora Update System 2009-06-15 21:21:15 EDT
nbd-2.9.12-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2009-06-15 21:44:57 EDT
nbd-2.9.12-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2009-06-15 22:08:29 EDT
nbd-2.9.12-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.