This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 496762 - Lines run together in screen tags in PDF builds
Lines run together in screen tags in PDF builds
Status: CLOSED WORKSFORME
Product: Publican
Classification: Community
Component: publican (Show other bugs)
2.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Hideo
Content Services Development
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-20 21:06 EDT by Deon Ballard
Modified: 2010-11-23 22:58 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-07 23:58:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
PDF example (48.58 KB, application/pdf)
2009-04-20 21:06 EDT, Deon Ballard
no flags Details

  None (edit)
Description Deon Ballard 2009-04-20 21:06:21 EDT
Created attachment 340463 [details]
PDF example

None of the linebreaks or white spaces in screen tags are honored in the PDF builds. I have publican 0.45 installed.

For example, I'll have something like this:
<screen>ldapmodify -D "cn=directory manager" -w secret

dn: uid=jsmith,dc=example,dc=com
changetype: replace
replace: cn
cn: John Smith</screen>

But in the PDF, it comes out like this:
ldapmodify -D "cn=directory manager" -w secretdn: uid=jsmith,dc=exam\
ple,dc=comchangetype: replacereplace: cncn: John Smith

This is with my local builds. I'll upload a PDF; see pages 2 and 4, for example.
Comment 1 Deon Ballard 2009-04-20 21:21:16 EDT
I'm setting this to an urgent priority. I have a release next week.
Comment 2 Jeff Fearn 2009-04-20 21:29:17 EDT
There are no urgent Fedora bugs that don't include crashing and/or trashing source.

The version of this doc in the ECS SVN repo builds fine for me.

Perhaps you should try pushing a draft in to brew and seeing if that works correctly.
Comment 3 Michael Hideo 2009-06-16 21:42:14 EDT
Hi Deon,

Is this still relevant? If so, please provide me a link to the source for testing.

- Mike
Comment 4 Deon Ballard 2009-06-17 13:36:13 EDT
Hi, Mike.

I think part of the problem was related to having inline formatted tags at the end of a line in screen. For example:

<screen>This is my first line, with a <replaceable>variable</replaceable>
tag at the end.</screen>

It would all run together, but if I put a character at the end like &nbsp;, then it worked as expected.

<screen>This is my first line, with a <replaceable>variable</replaceable> &nbsp; 
tag at the end.</screen>

Now, the example I had attached in the original comment, that wasn't the case, yet it was still running together. But I don't know what was wrong then; I re-installed fop and publican in the interim (same versions), and now it's fine.

I think you can close this, but I'll reopen and whine again if I need to. :)

Thanks!
Deon
Comment 5 Ruediger Landmann 2009-09-07 23:58:37 EDT
Unable to reproduce in 0.44 or 1.0.

Note You need to log in before you can comment on or make changes to this bug.