This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 496763 - spamass-milter generates a broken received header
spamass-milter generates a broken received header
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: spamass-milter (Show other bugs)
10
All Linux
low Severity urgent
: ---
: ---
Assigned To: Paul Howarth
Fedora Extras Quality Assurance
:
: 512519 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-20 21:22 EDT by Habeeb J. Dihu
Modified: 2009-11-18 07:55 EST (History)
3 users (show)

See Also:
Fixed In Version: 0.3.1-14.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-27 02:30:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch to correct typos in received header generation of spamass-milter. (638 bytes, patch)
2009-04-20 21:22 EDT, Habeeb J. Dihu
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Debian BTS 510665 None None None Never

  None (edit)
Description Habeeb J. Dihu 2009-04-20 21:22:58 EDT
Created attachment 340464 [details]
Patch to correct typos in received header generation of spamass-milter.

Description of problem:

There is a serious typo in spamass-milter that causes it to generate an improper Received header.  This causes spamassassin to generate quite a bit more false positives than it would otherwise.  This patch was originally created in response to a Debian report.  See: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=510665

I created a Fedora version.  Can you please get it pushed into the next update of spamass-milter?  This bug caused me almost 24 hours worth of headaches this weekend. :(
Comment 1 Fedora Update System 2009-04-24 16:01:13 EDT
spamass-milter-0.3.1-14.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/spamass-milter-0.3.1-14.fc11
Comment 2 Fedora Update System 2009-04-24 16:04:48 EDT
spamass-milter-0.3.1-14.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/spamass-milter-0.3.1-14.fc10
Comment 3 Fedora Update System 2009-04-27 17:41:24 EDT
spamass-milter-0.3.1-14.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update spamass-milter'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-4062
Comment 4 Paul Howarth 2009-05-20 12:20:33 EDT
This update will remain in the testing repository until I get some feedback on whether it actually works...
Comment 5 Fedora Update System 2009-10-27 02:30:09 EDT
spamass-milter-0.3.1-14.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2009-10-27 03:20:15 EDT
spamass-milter-0.3.1-14.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Paul Howarth 2009-11-18 07:55:20 EST
*** Bug 512519 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.